0

I recently had a little mishap on my PC machine and now my HDD is completely cleared.

I have a 32GB USB, a Windows 8.1 full DVD iso, and my macbook pro 2013 with Yosemite on it.

I tried using Bootcamp to install Windows 8.1 on my PC but it doesn't launch so I'm assuming that'd only work on a Macbook (for some odd reason). All I get is the annoying flashing underscore thing.

The steps I took in BCA were I launched it and selected "Create a Windows 7 or Later install disk" and it ran from there.

I checked out this question but it wasn't much help. Some say UNetBootin works others say it doesnt. I don't want to try anything that is not confirmed.

Any help is greatly appreciated.

  • and you tried this already? On a Mac create an ISO from the DVD and put it in a folder. Run BCA (Bootcamp Assistant) and use it to create a USB2 which will contain both the ISO and BC drivers. Uncheck the last "Install/Remove..." option, if you do not intend to install Windows on Mac. – Ruskes Apr 25 '15 at 21:13
  • I don't have the CD Drive. I got a digital copy of Win8.1 from my college. @Buscar웃 – NealC Apr 25 '15 at 21:14
  • Either way, make a ISO first. – Ruskes Apr 25 '15 at 21:16
  • I have the ISO.... I stated that in my question. I still don't completely understand your first answer. If you're telling me to try using the Bootcamp Assistant I've already done that. – NealC Apr 25 '15 at 21:17
  • Then please describe the steps you used in BootCamp to make the Bootable Windows USB, so we do not go around. – Ruskes Apr 25 '15 at 21:22
1

There's a simpler way than above. It's dd.

If you need a new .iso, Microsoft have Windows 10 USB ISOs on their website for download.

Plug the USB device into your mac, and open terminal.

Type diskutil list and note what the address of your USB is (should be /dev/diskX where X is a number).

If you don't have pv installed, it's worth installing because you get a progress bar for the next bit. If you have Homebrew, then you can just run brew install pv in terminal.

With pv:
type pv -ptearb <full .iso path> | sudo dd of=<your usb address>. You should get a prompt for your password.

Without pv:
type sudo dd if=<iso path> of=<your usb address>, enter password, and away you go. dd won't show a progress bar though, you need pv for that.

To speed up dd in both cases, you can use /dev/rdiskX rather than /dev/diskX.

Be careful with dd - if you get the device wrong, you could overwrite your OSX drive

  • Yeah, I asked this question before I had access to WIn10. Didn't think those commands would work for a Windows install though. Good to know now though. – NealC Nov 20 '15 at 16:28
  • 1
    If you get a Resource busy message, just unmount the drive with diskutil unmountDisk /dev/diskX – ThadeuLuz Sep 10 '17 at 1:37
0

The easiest solution would be to go and find a machine running Windows to create your USB installer. I also assume you have verified that the PC can boot from a USB port. Most of the newer machines can do this.

Having exhausted the easy way and if you don't want to spend any money, I suppose you could first install Windows 8.1 on your Mac. This would allow you to create the USB flash drive for use on the PC. I would suggest using Oracle VM VirtualBox since it is free and only takes 332 MB of space. I would proceed as follows.

  1. Download and install Oracle VM VirtualBox.
  2. To get access to a USB 2.0 port you will also need to install the Oracle VM VirtualBox Extension Pack.
  3. Install Windows 8.1 using the VirtualBox default settings except for the DVD drive. This drive will need to be mapped to the Windows 8.1 installation iso. When installing Windows, you want to be sure to not automatically active the software. Microsoft will allow you to use a non-activated version for about 30 days.
  4. Once Windows 8.1 is installed, shutdown Windows. Leave the iso file in the virtual DVD drive.
  5. Download the Windows USB/DVD Download Tool. The file name should be Windows7-USB-DVD-Download-Tool-Installer-en-US.exe. This file will be used to transfer the contents of the Windows 8.1 iso file to the flash drive.
  6. Format a 8GB or larger flash drive using the Disk Utility. You want a MBR partitioning scheme with a single ExFAT formatted partition. (I was able to use a 4GB flash drive with a MS-DOS(FAT) format. This may be because I was installing the Professional version of Windows 8.1)
  7. Copy the the Windows 8.1 installation iso file and Windows7-USB-DVD-Download-Tool-Installer-en-US.exe to the flash drive.
  8. Using the Disk Utility, unmount the flash drive. Once unmounted, add the flash drive to the ports of Windows 8.1 virtual machine.
  9. Start Windows 8.1. Copy the files from the flash drive to the desktop.
  10. Open a Windows Command Prompt Window as an Administrator. Enter the following command, then close the window. I assume your DVD drive has been assigned the letter D:.

    Dism /online /enable-feature /featurename:NetFx3 /All /Source:D:\sources\sxs /LimitAccess
    
  11. Open the Control Panel and select Programs->Turn Windows features on or off->.Net Framework 3.5 (includes .Net 2.0 and 3.0). You don't need the check mark, the small square will do. Click OK.

  12. Execute Windows7-USB-DVD-Download-Tool-Installer-en-US.exe to install the tool. A shortcut will appear the the desktop.
  13. Click on the shortcut to launch the "Windows 7 USB DVD Download Tool". Select the Windows 8.1 iso and the flash drive. Create the Windows 8.1 flash drive installer.
  14. Eject the flash drive and remove it from the computer.
  15. Shutdown Windows 8.1. At some point, delete Windows 8.1 from your Apple computer.

I have tested this procedure using a Windows 8.1 Pro 64 bit iso. I then booted a PC from the flash drive in EFI mode. My version of OS X is 10.10.3.

Final Note: The flash drive has a MBR partition scheme with a single NTFS formatted partition. I ran Windiff to compare the files in the iso with those on the flash drive. There were no differences.

0

You can give unetbootin a try.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .