How do I permanently delete text substitutions from System Preferences > Keyboard > Text. I have deleted them several times using the (-) key, but they annoyingly reincarnate themselves after a restart.


3 Answers 3


I have experienced this myself since OS X 10.10.1 and since iOS 8.1.x. I think it is an iCloud syncing bug. Old deleted entries return. Duplicates get created. I haven't attempted to, but I believe the only solution is to contact Apple support. Or wait for it to hopefully resolve itself.

  • How does contacting Apple support solve it? Commented Jan 31, 2017 at 18:11

Indeed a severe annoyance. I spent a lot of time on the phone to Apple and no solution was achieved, only "wait". I ended up doing a simultaneous reinstallation of OS X 10.10.3 and my iOS 8 devices and this has apparently made them go away. I have since upgraded to OS X 10.11 and iOS 9 and they disappeared for several months. However, they have just come back this AM for no apparent reason on startup.

  • 1
    I've had them come back even on 10.11 and 9. The problem is the cloud store of "truth" for this core data set isn't user-controllable. If an old device wakes from sleep it can continue to "reinfect" the set of shortcuts until you grow tired of deleting them.
    – bmike
    Commented Oct 22, 2015 at 15:42

Do you have any other Apple devices? Text substitutions get shared between all of your iCloud enabled products. I had a shortcut for my email address (backslash plus the word "email") that kept triggering all over the place, because iOS and OS X "helpfully" ignored the backslash - great when I wanted to plug my actual address in, terrible when "please email that file" got turned it into "please [email protected] that file".

The only way I was able to kill this was to delete the shortcut from all of my Apple products in quick succession - for me that meant iPhone, MacBook Pro, and iPad. You'll need to have all devices you signed in to using your Apple ID handy to do this. You may have to do it more than once for it to "stick". Good luck.

  • Yes, I had done that first. Dr. Nixon, just wait - not sure when, not sure how, but somewhere somehow you will [email protected] that file again...
    – EyeOjO
    Commented Dec 2, 2015 at 21:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .