5

Most of the instructions I've found online (this, for example) say all I have to do is select "show icon preview" in the finder view settings. But that doesn't seem to be working. What's the problem here?

This is OSX 10.8.5.

enter image description here

  • This happens when the system does not know the association (the application to use) to view those files, so it remains generic JPEG. – Ruskes Apr 25 '15 at 20:05
7

A couple of things to try.

Remove the Finder preferences file. The system will automatically regenerate it.

  1. In Finder, press Shift ⇧+Command ⌘+G and enter ~/Library/Preferences.
  2. Then find com.apple.finder.plist and move it to the Trash.
  3. Right-click on the Finder icon in the dock and select Relaunch.

If this doesn't work, ensure that JPG files are associated with Preview. To do this, right-click on one of them and choose Get Info. Under the Open With section, select Preview, and then click Change All. You may need to relaunch Finder with this method too.

7

This just happened to me and it was fixed by relaunching Finder:

  • Alt + Right Click Finder in the Dock > Relaunch
  • Cmd+Alt+Esc > select Finder > Relaunch
4

Any chance you have DropBox installed?

If so try this:
Go to /Users/youruser/Library/QuickLook/ and if there is a DropBoxQL.qlgenerator move it to the trash.
Then wait 5-10 seconds, and open a folder where previews weren't working.

DropBox will create a new DropBoxQL.qlgenerator when you login next (either logout/login or on restart) so if you want to prevent DropBox from screwing with your previews again then you'll need to put a dummy file in place.

In terminal run:

sudo touch ~/Library/QuickLook/DropBoxQL.qlgenerator

This will create an empty file owned by root that DropBox can't overwrite (since DropBox is running as your user when you log in).

This hasn't caused any issues I can detect on my Mac Pro (10.11.6) or MacBook Pro (10.12.2) but as always YMMV.

  • Many thanks for sharing this, was having difficulties with QuickLook on all types of files, turns out even after uninstalling Dropbox this file still remains. – Ben Everard Jan 2 at 11:36
2

When a file is not associated with a specific application, it will not show as Icon.

To change that right click on one of those files and select the Get Info, in that window select the Application to use to open, and then select apply to all (Change All).

apply to all

2

From this link: https://www.cnet.com/news/files-in-finder-not-showing-previews/

From the Finder's "View" menu select "Show View Options". Then select the option to "Show icon preview" and close the options window.

  • Looking for this. In column view it will be helpful. – Praveenkumar Jul 4 at 9:30
0

I spent a lot of time trying all of the suggestions above, but nothing worked. Finally I just turned the computer off and started it up again. Now it works.

-1

I have OS 10.10.5, and have what sounds like the same problem. I can see the icons again if I go into Finder -> View and then set the icons to the larger size. I can't seem to get the smaller view to work though.

After trying that, I also found that it I go to Finder -> Show View Options, then I can make the font in the finder window slightly larger and then the icons show up correctly. Then I don't have to make everything as big as the first method makes it.

You must log in to answer this question.

protected by Community Jul 3 '18 at 3:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .