1

I have an existing Yosemite installer app from the original release of 10.10 (e.g. Install OS X Yosemite.app) but can't seem to download a newer installer. When I click Download, I'm presented with this dialog:

Mac App Store window showing OS X Yosemite and dialog reading "OS X v10.10.3 is already installed on this computer. Use the Updates page to install the 10.10 update or if you would like to download the OS X installer click Continue."

However, clicking Continue doesn't appear to do anything. No update appears to be in progress, no network activity shows in Activity Monitor.

The same dialog appears if I click the Download button in Purchases, and the download never begins.

How can I get an updated installer?

  • Could it be you already have the Installer? if yes move it to another location and try again. – Ruskes Apr 25 '15 at 2:15
  • In that screen it is a very faint information, it would change the Download to Downloading, and a small spinning circle top left. No further information that it is actually downloading. There would be also a progress bar in the Finder window / Applications. – Ruskes Apr 25 '15 at 2:22
  • If you have a copy of the Install OS X Yosemite.app bundle anywhere on your computer it will get updated/overwritten if you click Continue. I moved the Install OS X Yosemite.app bundle that was for 10.10.0 from /Applications to /Temp and downloaded 10.10.2. It did not create an Install OS X Yosemite.app bundle in /Application as it normally would and I did not realize it until it was done and couldn't find it. That is until I saw that the 10.10.0 one in /Temp had been updated. I was irked as that was my only copy of 10.10.0. I like keep a copy of each installer but oh well, that's life. – user3439894 Apr 25 '15 at 2:44
  • @user3439894 - the trick is to move it to another partition, then the system can't 'follow' it. – Tetsujin Apr 25 '15 at 10:34
  • @Buscar웃: I do have a copy of the original 10.10 installer in my home directory, nothing in /Applications though. It's definitely not updating the copy I have in my home directory. The spinner doesn't appear to signify anything—it disappears when I click another tab in the MAS app and every time I go to Purchases, OS X Yosemite reverts to the Download button. – zigg Apr 25 '15 at 17:19
3

The problem appears to have been my copy of the installer that I had stashed away in a folder in my home directory, even though I'd originally made it by keeping a copy of the installer in /Applications (it was even owned by my user account instead of root!).

Once I removed that installer, the Mac App Store was happy to start the download for a new one.

  • Ahaah! Yes, unless you move it to another drive, or zip it & trash the original, etc,, the system will keep track of it. – Tetsujin Apr 29 '15 at 6:36
  • 1
    A note on the file being on another drive - mine was on another drive. I ejected the drive, restarted the AppStore and could then download it again. – Niall Sep 22 '15 at 10:54
2

I've seen this happen to a few people - it seems that the system is thinking in doublespeak - believing 2 things at the same time; that you need 10.10.3 but that you already have 10.10.3

Most times, this is resolved by downloading & installing the 10.10.3 combo updater, directly from Apple's Knowledge Base - https://support.apple.com/kb/DL1804

This will make sure you have all updated components since 10.10.0

  • Didn't work, unfortunately. Still same problem. – zigg Apr 25 '15 at 17:41
  • Then I'm not sure what the problem is… what are you actually trying to achieve? A standalone full installer? You would do that from Purchases. – Tetsujin Apr 25 '15 at 17:48
  • Also doesn't work. I get the same dialog, it switches to a grayed "DOWNLOAD" button, but never actually starts downloading. I have done it both ways before… – zigg Apr 28 '15 at 17:46
  • I still don't know what exactly you're trying to achieve, nor exactly what you've tried. You really need to explain more. – Tetsujin Apr 28 '15 at 17:54
  • Sorry, I wasn't aware the question was unclear. I have solved the issue since, but I'll update. – zigg Apr 28 '15 at 23:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .