My Macbook, Version 10.9.5 Build 13F1077, AppStore is somehow broken. It's like the formatting of it is broken. See attached image. Any idea's about what happened or how to troubleshoot or fix?


As a follow up to inquiries from @d-w @thomas-jones, yes, I am seeing bad formatting on some other Apple web pages. For example: Support.Apple.comIssue

  • Is your Internet connection through a filtering proxy?
    – user90735
    Commented Apr 25, 2015 at 0:44
  • Thanks for your reply David. No, just a cable modem and wifi router, no proxy or special configuration.
    – Sco
    Commented Apr 25, 2015 at 0:56
  • 1
    If this were a web page, I'd say that the CSS stylesheet didn't load. Sometimes this happens to me if I have a flaky Internet connection or a flaky DNS server. Can you reboot and try on another network? (Do you by any chance know how to use Wireshark or another network packet sniffer? If you do, you could look at it to try to troubleshoot failed network connections.)
    – D.W.
    Commented Apr 26, 2015 at 6:41
  • I agree it looks like the CSS style sheet is missing. I guess the app store is a single purpose web browser. I'll try to investigate network issues but I use the network all day so I'm doubtful that is the issue.
    – Sco
    Commented Apr 28, 2015 at 10:12
  • Notice how the SSL certificate verification has failed on the Chome screenshot? That's caused many a problem for me, most often the cause is incorrect Date and Time settings. Commented May 8, 2015 at 23:13

5 Answers 5


Try opening Terminal and entering the following command to enable the App Store Debug menu:

defaults write com.apple.appstore ShowDebugMenu -bool YES

Then, quit the App Store (if it was already open), and relaunch it. You should see a new menu after the Help menu labeled Debug. Open it and select Reset Application.

If that doesn't solve your problem, you might need to flush the DNS cache, the commands are listed below.

Yosemite: sudo discoveryutil mdnsflushcache
Lion, Mountain Lion and Mavericks: sudo killall -HUP mDNSResponder
Snow Leopard: sudo dscacheutil -flushcache

(to remove the debug menu from the App Store, enter the same command above used to enable it, and change the end from YES to NO.)

  • Thomas, thanks for your suggestions. I tried both but neither seems to have an effect. I have Mavericks so I did the sudo killall -HUP mDNSResponder. And I ran that as root in case that matters.
    – Sco
    Commented Apr 25, 2015 at 17:02
  • Do you ever experience similar problems when browsing websites? Commented Apr 27, 2015 at 5:10
  • No, I use a mix of Safari, Firefox and Chrome and have not noticed any other issues.
    – Sco
    Commented Apr 27, 2015 at 10:14
  • Actually @thomas-jones I do see some issues browsing apple websites. I edited my original comment, above, with a screenshot.
    – Sco
    Commented Apr 30, 2015 at 12:35

In case anyone's stylesheet is being blocked by a proxy, Apple seems to host the Mac App Store stylesheet at "s.mzstatic.com". I used the debug menu to download the page source and find out where the stylesheets were being hosted.

So, if you're facing network issues, ask your network admin to unblock *s.mzstatic.com* and you should be good to go.


I finally figured it out. In Keychain Access, I selected Preferences, then Reset my Default Keychain. After doing that, I restarted AppStore and it was working normally.

Warning You may loose other passwords stored in the Keychain, so make sure you have a backup of them

  • Such a strange problem, well, I'm glad you sorted it out :). Commented May 10, 2015 at 21:53

NO.. NO.. No, Nothing to do, It is purely CSS failure on server side on part of apple servers. Look at Apple discussions. Majority or All Macs upto sierra are affected and since these are Obsolete pieces as per apple..they are solving. Wait and watch...

  • They are solving? really. The question is 6 years old.
    – mmmmmm
    Commented May 1, 2021 at 11:33
  • 1
    @mmmmmm Regardless, they are correct that at the moment this issue is appearing for everyone on 10.11 – 10.13. It is on Apple’s end. Commented May 1, 2021 at 12:22
  • I think Girish means a server deploy failure will cause this for everyone for short periods of time. Of course more rare is when a Mac client is unhealthy or network is botched, this happens very rarely due to causes other than Apple messing up the code in a big way.
    – bmike
    Commented May 1, 2021 at 20:12
  • I strongly suspect Microsoft detatching all old customers (free service) to paid O365 silently... Commented May 3, 2021 at 16:47

Try resetting your computer's Date and Time, the settings are located in Apple Menu > System Preferences > Data & Time. If the "Set date and time automatically:" checkbox is enabled, disable it, and manually set the time and date correctly.

Try loading the App Store again.

  • Thomas, that had no effect. I even rebooted after but it didn't seem to make a difference.
    – Sco
    Commented May 9, 2015 at 20:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .