I'm using OS X 10.10 and my iTunes (version 12.1.2.x) keeps opening. the only behavior pattern I could observe seemed really bizarre - It would open when I would click in my Firefox window. I retested many times, but I couldn't reproduce this after I removed my headphones.

I checked for anything suspicious in /private/var/log/system.log. I didn't see any odd interactions between Spotify and iTunes (i.e. an event in one that led to an immediate event in the other when looking at timestamps). The only thing sort of suspicious were these logs (there were many of these entries) from iTunes when I wasn't using it at all:

/private/var/log/system.log:Apr 24 11:12:06 ITADMINs-MacBook-Pro-4.local iTunes[8626]: ### PlayQueue::StartPlayingNextInternal: played off the end of the queue
/private/var/log/system.log:Apr 24 11:18:37 ITADMINs-MacBook-Pro-4.local iTunes[8680]: ### PlayQueue::StartPlayingNextInternal: played off the end of the queue

What could be happening?

  • 1
    Do you have a Firefox add-on that would do that ?
    – Ruskes
    Apr 24, 2015 at 20:27
  • I have seen this happen when an application or a plugin gets hold of the iTunes scripting interface and doesn't release it correctly. Check for media player / media control remote / automation apps or plugins that could interface between a website playing audio or video and iTunes.
    – kopischke
    Apr 25, 2015 at 9:31
  • @kopischke This is an interesting suggestion, do you have any examples?
    – s g
    Nov 4, 2015 at 0:25
  • Also, this happens completely unprovoked. It's not necessarily when clicking something, typing, opening a new tab, etc.
    – s g
    Nov 4, 2015 at 0:50

3 Answers 3


WOW I finally figured this out.

Tampering with the audio jack will cause this to happen. I have headphones with the play/pause/skip control button, so the issue might not show up with standard headphones. If I tap (or double tap) the headphones where it is connected to the jack, the effect is the same as if I clicked the remote button that was designed to control playback.

What's happening is my movement is jarring the headphones and even a very slight tug will open iTunes and start playing music. Very frustrating when I'm using my headset for a phone call!

  • how to stop it ?
    – Dreams
    Mar 12, 2020 at 6:46
  • Use different headphones or be careful not to jostle the cable around. The choice is your, my friend.
    – s g
    Mar 13, 2020 at 23:07

You can solve this by running this in the terminal:

launchctl unload -w /System/Library/LaunchAgents/com.apple.rcd.plist

This will disable all remote controllers however.

More on this:



A nice app I found to stop this behavior is noTunes. It will run in the background and prevent iTunes from launching. It can be disabled in one click to make iTunes accessible again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .