0

I have a little snitch rule effective in all profiles to allow any process to connect to *.apple.com enter image description here Why do I keep getting request for applications to connect to apple.com? Here are 4 different processes requiring permission. I thought that the rule above should cover these...?? enter image description here

  • Try Domain apple.com - don't use the wildcard (on phone so pics are too small to read) – Tetsujin Apr 24 '15 at 4:47
  • @Tetsujin It actually removes the wildcard automatically so you're left with just apple.com – doovers Apr 24 '15 at 4:48
  • Hmmm... Ok. I'll have a look later when I'm back at my puter. I've never had the issue so there has to be a setting somewhere... – Tetsujin Apr 24 '15 at 4:54
  • @Tetsujin Me neither, it's been working for a long time for me and I've only noticed it recently. I think there was an update to LS recently too so this may have only become an issue since that update... – doovers Apr 24 '15 at 4:56
  • Check who the process owner needs to be in the main rule & who 'asked' in the on-demand rules – Tetsujin Apr 24 '15 at 13:54
2

On closer examination of the rule in the picture, it looks like it is set to Hostnames apple.com, not Domains apple.com, which may make all the difference.

If not, try adding a duplicate Domains rule also for System processes, as well as 'My' processes.

If that spits out any duplicates, you can then clear the others.
You may find some are locked - so disable or just leave as a dupe, it won't actually hurt anything.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .