4

How do I disable Safari in OS X?

The desired effect is the same as in iOS: in iOS, you can easily disable Safari through the Restrictions settings, and the app just hides but is not uninstalled. You cannot search for the app, see an icon, or open it in any way.

I do not want to disable all browsers. In fact, that's the problem. The Parental Controls control all web things. And that's great. But if I want the default browser to be Google Chrome and I want to use a whitelist, then I can't use Parental Controls (at least since Yosemite). The Parental Controls option for a whitelist has been blocking everything from Chrome. Firefox has similar problems, but not as bad as with Chrome. If I use Chrome and Chrome's parental controls, then a user can just open Safari with no restrictions.

3
  • Why? You've tagged "children": do you not want ANY browser enabled? If so, you might make a proxy that leads all web pages to 127.0.0.1 This might have unintended consequences for other quasi-browser related activity, such as other apps that leverage Safari's HTML/CSS rendering, which may include Mail.app, etc.. Apr 23, 2015 at 18:11
  • @CharlesLindsay I updated the question to clarify.
    – Joe Hansen
    Apr 23, 2015 at 18:15
  • As of OS X 10.11, you must disable SIP in order to do any of the solutions below.
    – Joe Hansen
    Nov 6, 2015 at 22:08

2 Answers 2

6

You could change permissions for Safari.

Open the information window on Safari (from the Finder window, with the Safari application selected, push command+I or right-click), add the desired user, and set permissions to no access.

13
  • +1 This is probably a better idea because if you ever deleted Safari and needed to restore it without making a backup or deleting it caused unintended system problems, the only way to get it back would be to reinstall OS X.
    – ajkblue
    Apr 24, 2015 at 2:55
  • 1
    Worked great. One note: when I added the user, I couldn't choose "No access", even if I was logged into the admin user when I tried to add the controlled user. However, it worked fine to leave the user off and mark "No access" for the "everyone" group. (All accounts use Chrome by default, so no big deal.)
    – Joe Hansen
    Apr 24, 2015 at 19:22
  • 1
    @Joseph It's saying that I don't have the permission to choose "no access" for everyone.
    – Airdish
    Apr 16, 2016 at 5:33
  • 1
    @Airdish With the update to OS X El Capitan, there are new security features that prevent users from tampering with System files. Not sure why they consider Safari a system file. But you have to disable the security if you have OS X El Capitan. stackoverflow.com/a/33640543/756329
    – Joe Hansen
    Apr 16, 2016 at 15:09
  • 1
    @Airdish In Terminal, you can type ls /usr/local and it will tell you if it exists. It is safe to disable security and then re-enable it. You should be able to find re-enable instructions in the link I posted, but the answer is simply: instead of the command csrutil disable you type csrutil enable when you're done.
    – Joe Hansen
    Apr 26, 2016 at 22:57
2

Just open the terminal and type:

cd /Applications
sudo rm -R -f Safari.app

It will ask for your password and proceed to delete Safari from the system. You may want to backup the app before.

5
  • This may be what I end up doing, but it might have unintended consequences with other apps that access Safari stuff. (This happens on iOS: you can disable Safari and still open links in your email in the Google Inbox app, for instance. If you delete Safari, that would not be possible.)
    – Joe Hansen
    Apr 23, 2015 at 18:23
  • 2
    I've used it like this for more than a month and no errors so far. Maybe I'm just being lucky haha.
    – Vextil
    Apr 23, 2015 at 18:24
  • That's useful information. I might do it, if no better options are found. You got my upvote!
    – Joe Hansen
    Apr 23, 2015 at 18:26
  • This might not work on El Capitan because of rootless
    – Matt
    Jul 22, 2018 at 0:08
  • You may wanna create a backup / change the location of the file instead of outright deleting it. Just changing the permission to ie 770 may still allow the system to update it
    – Julius
    May 24, 2021 at 21:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .