19

I had English language in iTunes Connect, but today it's changed to russian (I'm from Russia) and I cant find where to change the interface's language back to English (Russian localized - bad).

45

Found that very frustrating too (I'm Russian as well). It based on your "preferred language" settings in browser. If you use Chrome, it can be found there chrome://settings/languages, move "English" upper. That's it.

  • 7
    Spasibo, bro! =) – Legendary Apr 24 '15 at 12:15
  • It works like a charm!!! – King-Wizard Dec 12 '15 at 22:06
  • Great finding! Previously I thought it's about language preference of OS. – Nimit Pattanasri Mar 7 '16 at 4:38
  • 2
    йес, руссиан локализацион вери бэд, сэнкс гайз ))) – m8labs Dec 4 '16 at 12:47
  • 2
    I hate Apple. They are always ignoring a lot of things – user924 May 21 at 21:40
1

Maybe something has changed over the time, but the previous approach didn't work for me. My solution (macOS Sierra):

  • Open "System Preferences"
  • Open "Language & Region". There is list of "Preferred language" on the left panel. Click on the button "+" under the list and add English language as primary.
  • Reboot you mac.
  • Yeah, it was 2015 :) ty – Legendary Jun 28 '18 at 7:03
  • Didn't help either.. Russian language is like nightmare - popups everywhere – Mansurov Ruslan Nov 28 '18 at 23:44
  • It doesn't work. Tested on Google Chrome. It takes language priority from your web-browser and not your macOS! – user924 May 21 at 21:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .