0

I have a client that has upgraded from iPhone 5 to the iPhone 6. On the iPhone 5, exchange calendar worked just fine. We use the same setting for Exchange and it appears to connect. Unfortunately, the Exchange calendar does not show up in the list of calendars.

Yes, I have checked to make sure the calendars setting is on: Settings> Mail> Exchange> Calendars

We have deleted the account ans set it back up numerous times with the same result.

The problem isn't that the calendar DOES NOT sync. The problem is that the calendar simply DOES NOT even show up.

Any assistance is much appreciated.

2
  • 1
    If you go to Calendar app -> Calendars (bottom middle), have you verified that the Exchange calendar is turned on through there? – smoooosher Apr 22 '15 at 21:53
  • What was the iOS version on each phone? Did you migrate the data on the iPhone 5 to the iPhone 6, or just configured it as a new phone? – Jaime Santa Cruz Apr 23 '15 at 4:18
1

I had the exact same problem on my iPhone 6s. I tried to delete the Exchange account and add it back again, yet the Exchange calendar would not show up in the calendars list.

What finally helped in my case was quitting the Calendar app (not sure if that mattered), then going to Settings > Mail > Exchange and turning the "Calendars" sync setting off and then on again.

When turning off, you get a question whether to delete all Exchange calendar data. I accepted, and then turned the sync back on. When I started the Calendar app, the Exchange calendar finally showed up.

Make sure you backup your data before fiddling with the settings and removing calendars.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .