2

I have a friend who is currently in China.

We talk a lot using iMessage. The problem is that sometimes the iMessage isn't delivered and my iPhone sends it automatically as an sms (= fee !!).

I have enabled the option in the settings to do so, so that's the normal behaviour. But is it possible to enable it only for local numbers (not foreign) ?

I pretty much doubt it, but there's no harm in asking the question :)

  • How about you remove (or modify) his number (like skip the country code? – Ruskes Apr 22 '15 at 19:09
  • Or if your friend has both a phone number and an email address associated with iMessage, and you create two different contacts for them, one with only the phone number and one with only the email address, does that prevent iMessages to the email address from falling back to the phone number? You might have to delete your previous conversation thread to break the association between email address and phone number though. – nekomatic May 18 '15 at 8:47
2

It's an option similar to one I've previously searched in vain for - short answer is there is no granular control over whether or not to send as SMS.

The safest option is likely to be to simply disable 'Send as SMS' altogether.
Settings > Messages

| improve this answer | |
0

Search for Diagnostics in settings. In Diagnostics & Usage settings menu, select "Don't Send" instead of "Automatically Send" to avoid charges of international sms.

| improve this answer | |
0

I had similar issue, have made the following changes, hoping that this will prevent sending international messages

Navigate to Settings -> Messages -> enable iMessage if it is not enabled, then disable send as SMS option and finally disable iMessage.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .