Yesterday I upgraded to Lion and it seems it got some additions on Spotlight - the Developer and Web Searches groups.

Sadly I couldn't find a way to disable them. There isn't an option in the Spotlight preferences and I couldn't find the right defaults option.

Any ideas on how to hide them? They are cluttering Spotlight FAR too much :)

  • FYI, this is still happening at the age of Catalina :( Dummy Xcode.app solution still works :) Homebrew now reports "Xcode is not installed/outdated" :* – Halil Özgür Oct 22 '19 at 21:24
  • At this time, still only a partial solution is provided (for Developer). Another question (apple.stackexchange.com/questions/300352/…) suggests there may be or have once upon a time been a terminal command recipe to disable Web Search results in Spotlight, but I've not yet seen it. – texas-bronius Jan 9 at 6:26

I detailed a fix in this forum thread: http://forums.macrumors.com/showthread.php?t=1193533

  • 1
    This only works for removing the Developer category. – Oliver Ash Aug 13 '11 at 23:15
  • 4
    Welcome to Ask Different! The community appreciates answers that are more than just a link. It's okay to have al ink in your answers, but you must also summarize it in the answer itself. The idea is to make the answer able to stand on its own. Thanks! – Nathan Greenstein Aug 14 '11 at 4:10
  • Further explanation about Nathan's comment: what if the site you linked to goes down?... So will you please the text of your solution here as well? – Joseph Hansen Jun 19 '15 at 21:22

Spotlight thinks you are a 'Developer', if you have Xcode installed, or happened to install it at any time in the past, and hence shows you search results that maybe relevant to a developer.

When Xcode is actually installed and present on the computer, a check-box called 'Developer' appears in the System Preferences > Spotlight > Search Results panel giving us the option to disable 'Developer' results from appearing in our searches. When Xcode is not detected, the check-box disappears from the Preferences Panel, but Spotlight continues to show results from the 'Developer' category.

I am currently on Yosemite, and had installed and un-installed Xcode way back on Mountain-Lion or Lion, opting to use the 'Command Line Tools' instead. I also had Spotlight disabled until recently, and started getting hundreds of Search Results under the Developer category, once I re-enabled it. The clutter was making spotlight unusable.

Unable to find a solution anywhere on the Web, this is what I finally tried, and it worked:

I created an empty file called Xcode.app in the Applications folder, and the missing 'Developer' check-box showed up in Spotlight Preferences, which I could then un-check to solve my problem.

Open Applications > Utilities > Terminal.app then type and press Enter after each of the following lines to create the dummy Xcode app

cd /Applications
touch Xcode.app

then head to Spotlight Preferences and uncheck 'Developer' (you might need to restart the System Preferences app to see the missing check-box appear).


  • You need to keep the dummy Xcode.app even after changing the setting, deleting it will cause the setting to revert back.
  • Another solution would be to install Xcode itself
  • 1
    As noted, you have to keep the dummy Xcode.app, however you can hide the dummy Xcode.app file by executing chflags hidden /Applications/Xcode.app from the Terminal. Thanks to forums.macrumors.com/threads/… – Timo Tijhof Oct 1 '17 at 1:28
  • 2
    on mojave i no longer have to leave the Xcode.app dummy file. create the file, open spotlight settings and disable Developer, remove Xcode.app. developer no longer shows up – vampiire Jan 25 '20 at 4:47

As the top answer is a link to a forum post, below is the steps from post in case it disappears one day.

The fix below describes how to remove the spotlight developer category without installing XCode first.

Convert the plist to XML:

plutil -convert xml1 ~/Library/Preferences/com.apple.spotlight.plist

Open the file in the editor of your choice:

vim ~/Library/Preferences/com.apple.spotlight.plist

Just before </array> at the bottom, add the following:


Convert the file back to binary:

plutil -convert binary1 ~/Library/Preferences/com.apple.spotlight.plist

Log out and back in again.

  • 1
    This fixed it for me! Thanks for posting this solution directly here, instead of linking to the forum. – Albert-Jan Verhees Jan 24 at 10:01

Although the Search Results do not have toggles to sort or suppress these results, it's trivial to add the folders to the Privacy Pane.

Perhaps something like this might work to Suppress the Developer hits? enter image description here

I don't see an obvious way to suppress the Web Search yet, but thankfully it's placed last as a catch all - last resort. I'll probably feedback / bug Apple if 10.7.1 doesn't address that with a preference.

  • Well this means that I have to exclude my whole HD... :( – bisko Aug 11 '11 at 8:53
  • I've tried to get a flood of developer results but can't. It only contributes one, two or three hits to the bottom of the list spotlight window. What are you seeing and how could the developer files be anywhere but the developer folder? – bmike Aug 11 '11 at 13:27
  • As a web developer myself, I have a projects folder in my home dir. Every project have more than enough files in it and it just fills the spotlight results with items I do not want there. Not that it gets in my way or anything, I still get the results I'm looking for at the top, but it still annoys me to have them there. – bisko Aug 11 '11 at 14:43
  • Certainly file a bug - they added a class to the tool, it needs to be orderable/filterable like all the other categories of data. – bmike Aug 11 '11 at 14:50

Only one solution I could find, block all spotlight web access using little snitch. I guess this is up there with iCloud helping itself to your personal files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .