1

On a Mac running Yosemite, I moved my iPhoto library to an external hard disk, just by cut and pasting it. After running iPhoto, it could not find the local library anymore and asked me for the library location, I easily selected the external storage location, and it worked.

But now it does not import new photos from iPhone, just remains in "Preparing to import...". I tried to rebuild iPhoto library database, removing the related files Cache and Preferences of ~/Library folder, neither worked.

I even tried making an empty library in local hard disk and still the problem did not solve. This is while I can easily import photos from another user account on the same machine. It seems something is wrong with my user account.

Is there an idea?

1

After trying many different ways I could not fix iPhoto. However I succeeded to import photos to iPhoto. The trick was to run Image Capture, import photos using it and selecting the destination to iPhoto. It worked like a charm!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .