2

For some reason when my mac is at the login screen, moving my external USB mouse will cause the cursor to only move up and down. Once I am logged in, the mouse functions normally. Does anyone know the reason/fix?

Steps I have taken:

  • Reset SMC/NVRAM
  • Reinstalled OS
  • Tried another USB Port

Late 2013 15" MacBook Pro running Yosemite 10.10.3

with iHome wireless USB mouse.

I tested it and mouse works fine without problems on my Windows PC.

  • What type of mouse is it? Logitech? – Allan Apr 22 '15 at 14:57
  • It's an iHome wireless USB. IIRC it worked fine prior to Yosemite. – Weston Apr 22 '15 at 14:59
  • can you look back in the log after the boot started to see how it is identified (In the Console log) – Ruskes Apr 22 '15 at 15:08
  • A mouse is pretty basic tech and there's not much requried in terms of power. 5V is more than enough to operate the LED and camera inside your mouse (yes, it's a camera!) The first thing to check is if that mouse works on another computer. If so, then you are narrowing down your issue. Next, if you have another mouse, see if that works on your Mac. – Allan Apr 22 '15 at 15:15
  • @Allan good logic with one flaw. It works after the boot process is completed? – Ruskes Apr 22 '15 at 15:25
1

I'm assuming this is a USB mouse with a cord? I have seen issues with those not recognizing properly until login when connected through the USB ports on a keyboard, or on laptops. I've always accounted it to the mouse needing more voltage than the USB port is delivering until the user is logged in. This seems to be the case with older mice more often than newer ones.

  • It is iHome wireless USB. IIRC! Does your experience still applies ? – Ruskes Apr 22 '15 at 15:10
  • It depends, after googling "iHome wireless USB mouse" it looks like your mouse might be a bit older. I'd be willing to bet that the receiver is using more voltage (probably 5v) which is getting getting picked up by the OS until the computer logs in. The instances I've seen this problem occur have been with older Mice all over 5 years old on new machines. For example Microsoft mouse (2010) will recongnize on 2012 Mac Pro, but not the new Mac Pro. Can you try a newer mouse? – Mojoscream Apr 22 '15 at 15:17
  • I found this article on the USB power matter. support.apple.com/en-us/HT204377 There are a few things in there you can check. You might also want to check and make sure there aren't any drivers you have to install from the manufacturer, or if there are drivers installed, see if there are newer ones that are Yosemite compatible. – Mojoscream Apr 22 '15 at 15:23
  • That Voltage logic would not cut it, it works after the boot process is completed. – Ruskes Apr 22 '15 at 15:28
  • 2
    I can't see how voltage would be the problem. A USB mouse draws no more than 50mA or less of power. That's 10% of what the USB port is capable of 500mA (half an amp). If you want to check power, plug in a USB Hard Drive. If it power up, power is good on the Mac side of things. Chances are, you have a mouse with a faulty or incompatible (with Yosemite) driver. – Allan Apr 22 '15 at 15:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .