1

Heads up, I have a similar problem such as in this question, but it wasn't resolved:

how to debug configure.sh errors when compiling rsync on Yosemite

So basically I am looking to compile code via the command line, which works fine with clang++, but when i use gcc/g++ I get this warning:

g++: Warnung: kern.osversion nicht erkannt: »14.3.0

This line in english would be:

gcc: warning: couldn't understand kern.osversion '14.3.0

When I type g++ -v, this is my answer:

g++: Warnung: kern.osversion nicht erkannt: »14.3.0
Es werden eingebaute Spezifikationen verwendet.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=/usr/local/libexec/gcc/x86_64-apple-darwin13.1.0/4.9.0/lto-wrapper
Ziel: x86_64-apple-darwin13.1.0
Konfiguriert mit: ../gcc-4.9.0/configure --enable-languages=fortran
Thread-Modell: posix
gcc-Version 4.9.0 (GCC) 

As mentioned before, typing clang++ -v gives:

Apple LLVM version 6.1.0 (clang-602.0.49) (based on LLVM 3.6.0svn) Target: x86_64-apple-darwin14.3.0 Thread model: posix

So all good.

Now since clang++ and Xcode compile fine, why bother you would say, but I just tried to install gnuplot and that doesn't work at all and the gcc problem keeps appearing.

I would be so grateful if someone new what was wrong. At the least it would be good to know how to install gnuplot without gcc functioning. I tried the install with the usual commands: ./configure make make install

Thx a lot!

P.S. I run Yosemite and am pretty sure (installed it like 3 times) that I have installed the latest command line tools. As I gather from the discussion in the other thread is that something might have been installed by hand which should not have been. Unfortunately I am not that good with unix etc. that I'd be able to figure out what went wrong.

Edit1: Many threads that I find with a similar issue have as solution that the command line tool are installed. Just to be sure I typed again:

xcode-select --install , which gives me:

xcode-select: error: command line tools are already installed, use     "Software Update" to install updates

Edit2: This link https://github.com/Homebrew/homebrew/issues/36944 seems to have a similar problem, and it is also ressolved, but I cannot make their solution work as I don't know what brew is, nor do I have gcc-4.9 working. But I thought this might give a hint.

Edit3: As is suggested in one of the comments, I tink the problem lies in too many different version of gcc (and other stuff) being installed in various places. I have managed to now link to the recent version of gcc I installed with homebrew so that g++ works as a compiler, but gcc still does not work. I also still get the kern.osversion warning. So the problem is not really solved. I would still be interested in someone maybe showing me how to get rid of every compiler, command line tool, and what not and start from scratch...

  • Are you using the most recent version of Xcode and the command line tools? – nohillside Apr 22 '15 at 13:42
  • Yes, I checked numerous times that they are installed, so I am pretty confident with that! – GermanExpress Apr 23 '15 at 14:00
  • What is the output of type clang++; type gcc? – nohillside Apr 29 '15 at 13:30
  • Also, apple.stackexchange.com/questions/180750/… shows a similar problem – nohillside Apr 29 '15 at 13:33
  • output of type clang++ is: clang++ is hashed (/usr/bin/clang++) and the output of type gcc is: gcc is hashed (/usr/local/bin/gcc) – GermanExpress Apr 29 '15 at 13:35

You must log in to answer this question.

Browse other questions tagged .