4

I've been using Calendar with iCloud for a long while without any problems. Now, I have a permanent error displayed in Calendar:

The request for account “iCloud” failed.

The server responded with “400” to operation CalDAVAddSubscriptionCalendarQueueableOperation

I've searched around online and have tried all of the proposed solutions, but none of them seem to fix the problem. What should I try next?

  • Hard to say without knowing what you've tried so far... – Tetsujin Apr 22 '15 at 13:00
  • 400 is the missing of correct Internet address. Check your settings. – Ruskes Apr 22 '15 at 15:11
1

Lets try this to Reset your iCal operations.

Back up calendars and Disable calendars in iCloud Preferences :

Go to:

  • ~/Library/Calendars

  • /Library/Preferences/com.apple.CalendarAgent

  • /Library/Preferences/com.apple.iCal.plist

Move all to the desktop.

Restart.

  • how do you back up calendars and how do you disable them ? – Kalamalka Kid Mar 24 '16 at 3:18
  • So after you move the files to the desktop and restart then what? Do I delete the file from the desktop, copy and past back into ical, trash the folder??????Dont want extra files living on my desktop – Tyler M. Nov 16 '17 at 4:21
0

I am running Yosemite 10.10.5 to make this happen I had to first Show All Hidden files by:

1) Open Terminal and type the command: defaults write com.apple.finder AppleShowAllFiles YES

2) Hit Return

3) Mouse over the Finder icon, hold option, right click and relaunch finder

4) Open a new Finder window and navigate to: /Users/username/Library/Preferences/

5) Locate the two files: com.apple.iCal.plist, com.apple.CalendarAgent

6) Move them to the desktop and restart

This is different than the instructions above in that the location of the folders you're looking for may or may not be in the same place depending on which specific version of OS X you're running. This is the only place I was able to find the files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .