1

I've got a Late-2011 15" MacBook Pro stuck in the gray screen when booting AFTER login. I've tried removing the drive (it's non-retina) and booting from a working bootable Yosemite installer, no luck. (it sees the startup USB drive, the progress bar progresses, but stuck at the gray screen again even without a drive.

Tried NVRAM reset (cmd option P R), it has reset (the login sound's volume changed) but nothing changed.

Tried holding D on startup, AHT doesn't start, instead, it tries to boot into the OS.

Tried Cmd V, it sometimes works and displays the verbose output, sometimes, it acts like I haven't even pressed. Again, stuck after login.

Tried booting again from USB, I select USB (after seeing both drives correctly), but no luck, it's also stuck.

I've stumbled upon this:

Boot hangs on grey screen (even when booting from USB drive with fresh OS X install)

I've tried booting into single user mode with Cmd S, it worked ONCE, I've disabled the graphics extensions just as shown at that post, restarted, but again, nothing changed.

More weirdly, now the Cmd S doesn't work either. It just takes me to login screen without showing the terminal, just as I haven't pressed anything.

Why would this happen? Why would a Mac refuse to enter hardware test mode, single user mode, or refuse to boot from a working bootable Yosemite drive both with or without the main drive installed?

UPDATE: I've run the AHT and got an error:

4MEM/66/40000000: 0x84e0ec98

It looks like a memory issue, but I'm not sure.

UPDATE 2: I've tried reinserting the RAMs and the the problem is not reported anymore. However, the Mac still won't boot.

  • Just a note - cmd/opt/p/r is PRAM/NVRAM reset not SMC reset - see support.apple.com/en-us/HT201295 – Tetsujin Apr 22 '15 at 13:03
  • @Tetsujin my bad. it was an NVRAM reset. corrected. I could now get into interned-based AHT by option-D, it's performing the test now. If it doesn't solve, I'll also do SMC reset. – Can Poyrazoğlu Apr 22 '15 at 13:08
  • wish you luck... – Tetsujin Apr 22 '15 at 13:11
  • You are right, it is RAM problem. Since you have more than one, take one at the time out and test. – Ruskes Apr 22 '15 at 14:57
  • One of the first things in the boot process is the self test (hardware), in your case it passes sometimes and sometimes not. If you are lucky, it could be just the RAM socket not seated properly. – Ruskes Apr 22 '15 at 15:02
2

http://www.apple.com/support/macbookpro-videoissues/

Apple has issued a Repair Extension Program for Video Issues. I was experiencing the same problem and had tired several solutions that worked for a short period of time, but ultimately I was unable to get my MBP up and running last night and brought it into an Apple store. They determined that my issues was in fact a video issue and qualified for free service.

If you purchased a MBP between February 2011 and December 2013 and suspect that your MBP is experiencing the same issue, then check out the page URL above to see if your MBP qualifies for service.

Here's an excerpt from the page

=========

Apple has determined that a small percentage of MacBook Pro systems may exhibit distorted video, no video, or unexpected system restarts. These MacBook Pro systems were sold between February 2011 and December 2013.

Apple or an Apple Authorized Service Provider will repair affected MacBook Pro systems, free of charge. See below for details on affected models and service options.

Symptoms

An affected MacBook Pro may display one or more of the following symptoms:

Distorted or scrambled video on the computer screen No video on the computer screen (or external display) even though the computer is on Computer restarts unexpectedly

Products affected 15-inch and 17-inch MacBook Pro models manufactured in 2011 15-inch MacBook Pro with Retina models manufactured from Mid 2012 to Early 2013

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .