Why are the accountsd and securityd processes using so much CPU on OS X 10.10.3?
I am on a Early 2011 Macbook Pro.

What are these processes for? Is it safe to kill them? The machine has only been up 4 hours so has been rebooted recently.

enter image description here

  • Comments are not for extended discussion; this conversation has been moved to chat.
    – bmike
    Commented Oct 2, 2020 at 13:35
  • Apple has released fixes for this on 10.14 and 10.15 - see the meta post for details: apple.meta.stackexchange.com/questions/3970/…
    – bmike
    Commented Oct 2, 2020 at 13:36
  • I don’t have rep to answer; I am on 10.15.7, and the issue started after logging into new gmail account on Safari; it opened an incognito page to let me login again, saying “configuration will continue in Internet Accounts”. Then, accountsd memory and CPU usage is pegged at capacity. Disabling Spotlight on entire disk did not help. Later, I disabled everything in Internet Accounts (incl. Apple ID, and I deleted iCloud keychain (to be re-synced later)). This did not work yet, but upon rebooting, everything is tentatively normal. I re-logged in to iCloud and synced passwords w/o problem. Commented Oct 6, 2020 at 9:49

17 Answers 17


In Mail.app's application's preferences, I deselected "Accounts > Advanced > Automatically Detect and Maintain Account Settings" on two Google accounts, and CPU usage returned to normal.

  • 1
    this worked, however it cause Gmail account configured with two factor authentication to stop working...
    – mkrus
    Commented Jun 12, 2015 at 18:55
  • 1
    @mkrus One of my accounts is a Google for Work ([email protected]) and one is normal ([email protected]). I also see accountsd crashing on a desktop machine...
    – nop
    Commented Jun 13, 2015 at 1:24
  • 1
    Perhaps you might configure a 'fake'/invalid account, only to get access to preferences pane. Commented Feb 10, 2016 at 16:58
  • 12
    This option does not exist anymore in 10.13.
    – slhck
    Commented Sep 28, 2018 at 7:52
  • 1
    I disabled the Mail Preference > Accounts > [ Your mail ] > Server settings > Automaticlly manage connection settings, seems like works.
    – Oboo Cheng
    Commented Feb 22, 2020 at 12:07

This issue appeared with macOS Catalina for me, and only if I have the Mail app open without an internet connection.

Going to Mail->Window->Connection Doctor->ShowDetail, it looks like there's an infinite loop running, which tries to connect to the mail server.

The only temporal solutions are to either disable the account which is causing trouble (via Mail Preferences) or to quit the Mail app when I'm offline.

EDIT (about one year after original post): The issue has disappeared for me, without me changing anything on my system.

Apparently either Apple or the email provider have fixed the issue.

  • Thanks @FizzleDizzle this actually worked for me... for me it was a connection to my ProtonMail-Bridge that showed the same behavoir... I'm pretty certain, that i unchecked the 'Automatically manage connection settings' checkbox when trying to unsolve this issue in the first place... now having this checked again, it seems to work... wonder how it's gonna be in long term..
    – Darkglow
    Commented Feb 6, 2020 at 12:52
  • same here for me; since fresh install of Catalina, no internet = accountsd has 240+% CPU usage. Commented Jun 16, 2020 at 17:39
  • The fix for this on Mojave is to install the 10.14.6 Supplemental Update - build 18G6032
  • The fix for this on Catalina is to install the macOS Catalina 10.15.7 Update - build 19H2

After the reboot - check for build versions and that no OS updates are available. You don't need to delete any accounts or keychains or internal database files if you can patch your Mac with the Apple fixes.

The same problem still exists in 10.15.5. Some people have data in iCloud that triggers accountsd to loop. I followed the instruction from: https://waal70blog.wordpress.com/2019/12/16/accountsd-and-secd-high-cpu-usage-on-catalina/

You will see a folder that looks like a keychain under ~/Library/Keychains/ and you need to replace the xx...x part with that keychain.

Solution: sudo rm -rf ~/Library/Keychains/xxx-xxx-xxxx-xxxxx and reboot.

Another set of triage steps is published at this site that lists many details from the perspective of people that administer Macs professionally.

  • 2
    This worked for me this morning on OSX Catalina, 10.15.6. Commented Sep 24, 2020 at 14:20
  • It worked for me as well. Thanks for your input.
    – AlexHalkin
    Commented Sep 25, 2020 at 11:46
  • 9
    In my case, my Apple ID is the cause. This morning, accoundsd suddenly started using over 300% CPU. I deleted my local keychain & restarted iMac, but that's not solved. Then I happened to look at System Preferences > Apple ID, that said something like " (!) You should update Apple ID info". So I signed-out Apple ID, then, accoundsd's usage dropped to ZERO % CPU. That was super fast...
    – Tak
    Commented Sep 25, 2020 at 21:40
  • 3
    I made signing out of Apple ID it's own answer as it's less destructive than wiping all passwords and worked for me.
    – OrigamiEye
    Commented Sep 29, 2020 at 7:33
  • 2
    Just tried it with 10.15.7. Did not work for me. The moment I restarted it came back to 400% CPU. Commented Oct 1, 2020 at 14:44

It sounds like that there is a bug in the file indexing of iOS. Sometimes, accountsd gets stuck in an indefinite loop while indexing the files in the computer (for Spotlight use). The way to solve it is to reset the indexing on your laptop:

  1. Go to System Preferences-> Spotlight-> Privacy
  2. add (+) your hard disk (most probably "Macintosh HD") in the "Prevent Spotlight from searching these locations" list.

This will erase your previous index file and should solve your problem with the high usage of accountsd. However, Spotlight won't work any more. If you don't need it, don't bother to follow the rest of the instructions.

But if you need Spotlight back, remove Macintosh HD from the list by selecting it and clicking the - button. Do this over the night or sometime that you don't need your laptop for few hours as it is going to reindex your files and takes a lot of computer resources.

  • 1
    This has solved the issue for me. After a fresh install, I did not even open the Mail or Calendar apps so I was a bit puzzled by the other answers. I think the easiest way to check whether this can be the cause of the problem is to simply try and use spotlight; for me it was not working when accountsd was going crazy. Unfortunate though that it requires to reindex the drive.
    – Oliver
    Commented Sep 27, 2020 at 11:41
  • 1
    It appears clear from the success reports for various solutions that there are various underlying problems. This was it for me though, thank you for posting this! The easy test of "is Spotlight working?" hinted this might be it when my Spotlight was not working at all. Following this procedure fixed it. Occurred for me after the OS update from 10.15.6 to 10.15.7
    – Mike Hardy
    Commented Sep 27, 2020 at 15:38
  • Exactly the same as @MikeHardy — this started happening to me with the update to 10.15.7, and Spotlight failed to work just as described, which gave me the correct hint as well after reading the other the answers. (Indeed this fixed the issue for me) Clearly there was a problem with this specific version.
    – waldyrious
    Commented Sep 28, 2020 at 21:56
  • Thanks a lot, removing Keychain DB and loosing all passwords looks like a pretty hard choice, and now CPU just chillng )). Commented Sep 29, 2020 at 7:55
  • For me, too, the issue appeared first after the upgrade to 10.15.7. Spotlight stopped working and CPU usage was insanely high. I have now added Macintosh HD to the Spotlight ignore list in the "Privacy" tab and waiting for the CPU usage to drop...
    – robert
    Commented Oct 1, 2020 at 9:08

What worked for me (macOS 10.15.7) is signing out of Apple ID and restarting. Logging into Apple ID brought the issue back so from reddit the following terminal command permanently fixed the issue

sudo -v
killall -9 accountsd.iCloudHelper
defaults delete MobileMeAccounts
mkdir ~/Library/Accounts/Backup
mv ~/Library/Accounts/.sqlite ~/Library/Accounts/Backup/
killall -9 accountsd.iCloudHelper
sudo reboot

My symptoms were accountsd at 300%, no apps open, slow spotlight.

You can also check in Console application to see if accountsd has recorded any errors. Just open Console and enter "accountsd" . This is taken from an answer on a different thread, and probably the best place to start.

I tried the answers posted in this thread but none worked. At the time of my post they included:

  1. Quit Mail
  2. Remove Google accounts from Mail, Calendar (need to resync after reconnecting)
  3. Add Macintosh HD to Spotlight privacy so it would not be indexed (HDD will need be indexed again by spotlight)
  4. Delete all passwords in ~/Library/Keychain (Deletes passwords locally, but can resync from iCloud)
  5. Signing out of AppleID (deletes all iCloud files on machine)
  • Good call out. Mind an edit to explain which of these does not delete data or cause data loss and which things do cause loss of saved passwords?
    – bmike
    Commented Sep 30, 2020 at 12:11

I had similar issue with accountsd using 44 % CPU. The following steps solved the issue.

In Calendar.app > Preferences > Accounts... I disabled and enabled the account that Mail and Calendar kept trying to access.

  • 1
    I didn't even have Mail.app open and saw accountsd at 120% CPU, for me it was also unchecking the gmail accounts from the calendar that quieted the process. Commented Jan 3, 2018 at 18:23

I had a Gmail account that was closed still signed into my Mac's system preferences.

Once I removed the account, accountsd went from 83% CPU to 0.01 after 30 seconds, my CPU temp went down from 183F to 106F, and my fans stopped running at high speed.

I agree with most in regards to a Gmail account being the common denominator.


Could you please try to log out of all you iCloud Services, reboot and login again.

I have the same issue, which occurs randomly. I'm suspecting iCloud or my Mail accounts in System Preferences. From time to time systems preference pane is asking me to enter my google passwords, which I decline to do.

  • I tried this, but it didn't solve the problem for me. Logging out from iCloud is a pain because it takes quite some time to set it back up the way it was before. Only try this as a last resort I would say.
    – Zweedeend
    Commented Aug 4, 2015 at 13:28
  • I had the same problem on MacOS 10.15.6 and 10.15.7: 6 of the 12 CPU's of my MacBook Pro were running accountsd amounting to a CPU usage of up to 500%. Signing out of my Apple ID (which I think is the same this answer suggests) resolved this issue for me. Also, after signing in again, the problem did not return. Commented Sep 28, 2020 at 8:46

I run into the same problem yesterday on Catalina 10.15.6 and after having tried many different things, I could finally solve the problem by resetting the NVRAM (Non-Volatile Random Access Memory) with the command


upon starting (I also posted a question for that issue there: process in /System/Library/Frameworks/Accounts.framework/Versions/A/Support/accountsd taking almost all ressources of computer)

Note: I previously tried the following (as indicated in this post) but it didn't work:

  • I deleted all the account in `system preferences > Internet accounts' (didn't work)

  • I rebooted 2x the machine in safe mode by holding shift (didn't work)

  • 1
    This worked for me after the update to 10.15.7.
    – Dirk
    Commented Oct 1, 2020 at 15:28
  • This. The Mail solution doesn't work in current os version.
    – Damb
    Commented Oct 2, 2020 at 21:06

I had the same issue on macOS Catalina 10.15.7. I tried many solutions mentioned here but none of them solved the issue.

In my case OnyX app helped. I went to Maintenance and run with the following options (probably not all of those are needed). OnyX is available at https://www.titanium-software.fr/en/onyx.html

enter image description here

  • This worked for me. Situation was pretty bad. Onyx has always been an useful tool. I also cleared the NVRAM afterwards just in case. Commented Oct 5, 2020 at 10:49

Per someone else's suggestion on a similar thread, I deselected the Mail > Preferences > Accounts > Advanced > Automatically Detect and Maintain Account Settings and the CPU dropped back to normal range. I have 3 google, 1 yahoo, and iCloud accounts. Hopefully this fix will stick. I had run Disk Util multiple times for same issue, and there seem to be continual permissions errors popping up, so not sure if another underlying process or this was it. Good luck!


I got accountsd to quiet down by exiting and restarting the Mail app. It went from around 60% CPU to 0% CPU. No reboot was required.

I'm not sure what triggered its bad behavior, but I was looking at my accounts and provisioning profiles in Xcode for a very long time.


In the Mail app, go to Window > Activity and try to cancel everything it is doing. That solved it for me

  • The earlier mentioned "Mail > Preferences > Accounts > Advanced > Automatically Detect and Maintain Account Settings and the CPU" fix was only part of the answer for me. Turned out, Mail was stuck in a loop trying to synch an account that had been disabled earlier. Manually canceling immediately solved the problem.
    – D. Simpson
    Commented Jul 11, 2015 at 19:20

Unchecking Calendars and Messages in my Google account solved it for me. It is no loss to me, regardless, as I only use Google for some mail at the moment (which I left selected). As to why this was an issue with Google, and why it only became an problem recently, I am at a loss.


I met this problem when I just updated to 10.13.6, too. And I happily find this problem disappear after I restart my MacBook Pro (Retina, 13-inch, Early 2015).


I solved increasing the space on iCloud.

  • It won't work if you already have the biggest available option for iCloud.
    – Kris
    Commented Sep 29, 2020 at 8:17
  • yep, but in my case fortunately it worked. My Mac was becoming unusable.
    – ozw1z5rd
    Commented Oct 2, 2020 at 15:06

I tried all solutions. None worked. In the end, I had to remove all Google Accounts from Catalina and use in the web browser instead.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .