0

I recently rebooted an OS X machine on which I had an ongoing conversation in Messages via text with a phone number on a non-iOS phone. Now, though I am able to continue sending texts from Messages on iOS to exactly the same number, I can no longer send texts to that number from Messages on OS X, instead messages fail to send, the two conversations are no longer synced between OS X and iOS, and I'm told that the "phone number is not registered with iMessage".

How do I get OS X Messages to remember that I can, in fact, text that number?

  • I would try the steps noted here: macrumors.com/2014/11/06/text-messages-phone-calls-on-your-mac Go through and turn text message forwarding off then on again for that device, and then proceed from there. A few good troubleshooting tips at the bottom of the page, too. – smoooosher Apr 21 '15 at 17:41
  • 2
    in your phone, under settings -> messages -> text message forwarding is your mac listed and active? – Matte.Car Apr 21 '15 at 17:42
  • @Matte.Car: Incredibly (typically? frustratingly? Apple-ly?) no. The reboot of my Mac apparently disabled this setting on my iPhone. Hurray for security! – orome Apr 21 '15 at 17:49
  • Strange, it never disabled for me... – Matte.Car Apr 21 '15 at 18:09
  • @Matte.Car: Weird stuff like this happens more and more. – orome Apr 21 '15 at 18:52
3

Check "Text Message forwarding" under phone Settings > Messages > Text. This must be on (and your iOS device and OS X machine must be on the same network) for text messaging from Messages on OS X to work.

(It's possible this was disabled disabled for his Mac after a reboot.)

| improve this answer | |
0

Not sure for txt, but if that happens for iMessage, then reselecting the 'correct' number from the To: someone header above the text area [even if it looked right to you in the first place] can make it have a rethink.

The area would show as red before, blue or green after 'fixing'. If 'no fix' is required then there is no colouration to that part until clicked on.

I don't have a red example right now…

enter image description here

Also, make sure their number in your Contacts is not listed as iPhone - mobile or cell should be OK.

| improve this answer | |
  • Yes, that's what occurred to be to try first. But it doesn't work. It thinks things are fine for a second (or claims to think it does) and then fails again as before. – orome Apr 21 '15 at 17:38
  • I had one number on my phone last year that went like that - but this was before SMS from Mac capability, so I'm not sure what's changed in how the Mac 'thinks' of the contact info, sorry. apple.stackexchange.com/questions/148579/… but there was no resolution [it was 'fixed' when they actually bought an iPhone] – Tetsujin Apr 21 '15 at 17:43
-2

On your computer, use AIM (AOL instant messaging, aim.com . it synchs with Imessages (just add the account), and it is happy with phone numbers. Enter the phone number there.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .