1

Question says it all. Current versions of Yosemite (10.10.3) and Server (4.1).

Under Server > Settings Enable screen sharing and remote management checked.

Under Server > Access Admin and a non-admin local user listed.

I can log in Screen Sharing as the Admin user but not via non-admin accounts.

  • Did you add the non-admin user (or non-admin group) to the Remote Management pane itself in SysPrefs? – smoooosher Apr 21 '15 at 16:28
  • Bingo, that was the ticket. I had been ignoring it due to the "Screen Sharing is currently being controlled by the Remote Management service." message. Seems counterintuitive. Convert your comment to an answer and I'll give you credit. – Guy Heckman Apr 22 '15 at 2:44
1

Be sure to add the non-admin user/group (depending on if multiple users) to the Remote Management section of Sharing in System Preferences to allow access.

(Thanks Guy!)

  • While it seems counterintuitive given that you can grant access to services via the Server App the big warning in the System Preferences pane actually is telling you what needs to be done. If anyone has any insight as to the logic of why Apple made this functionality a two step process I'd like to know. Thank you in advance and thank you smoosher for the quick answer - I had been banging my head against it since setting up a Mac Mini with Server. – Guy Heckman Apr 23 '15 at 15:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .