I've got a 2010 MacBook (MacBook7,1) with 8GB RAM running Mavericks 10.9. I recently replaced the stock HDD with a Samsung 850 EVO 250GB SSD and restored from a Time Machine backup. Though Disk Speed Test reports performance going from ~50MB/sec to ~250MB/sec (what you'd expect for the SATA II interface), I can hardly tell the difference in performance or even battery time.

For comparison, when I did an SSD upgrade for my OS drive on my MacPro3,1 it was honestly night-and-day; I figured that I should see the same with the MacBook. Unfortunately, boot times are only slightly improved and general performance of doing things seems hardly any better. For example, launching (say) Calendar.app on the Mac Pro went from several bounces on the dock to 1. I'd honestly say that the MacBook is bouncing the same number of times as are other applications.

I do realize that the MacBook7,1 is a less powerful machine than the MacPro3,1 but honestly I am really surprised how little performance difference there is. Any thoughts on what I could check or has anyone else observed the same/different with their MacBook?

FWIW, I am still on Mavericks due to smart card handling changes in Yosemite that prevent me from using the laptop for remote working with the office (Citrix hasn't patched it yet). As well, I HAVE installed Trim Enabler and did make sure the patch was activated.


I had the same issue with the Samsung SSD. The main issue appeared to be with spotlight indexing. After installing the SSD the drive would not index. If you click on the spotlight search does it show indexing with a progress bar and estimated time with no estimate? If so this answer will help fix your issue. I tried several fixes before I solved the issue.

To turn off indexing you can do the following:

  1. open the terminal app
  2. type sudo mdutil -Ea -i off

This should help with performance issue if indexing is the cause. Thanks svenper for the "E" addition.

  • Doing both of these is counter-productive. I would advise doing it in reverse order, but that same result could be produced more elegantly just adding the -E option to mdutil. sudo mdutil -Ea -i off. Indexing is discouraged on SSD’s as they are fast enough without it, so your advice may actually worsen performance (relative to my solution, not the current state). – user118108 Apr 21 '15 at 6:07
  • 1
    I was not suggesting doing both but what you are saying about indexing on an SSD makes sense. Editing my post to remove that option. – jimrice Apr 21 '15 at 6:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .