2

Was trying to run the Java update earlier. But it couldn't launch the installer after downloading. Here's the log:

21/4/15 12:35:58.498 am Java Updater[814]: Original euid:501
21/4/15 12:35:58.500 am Java Updater[814]: Host name is javadl-esd-secure.oracle.com
21/4/15 12:35:58.500 am Java Updater[814]: Feed URL: https
21/4/15 12:35:58.500 am Java Updater[814]: Hostname check passed. Valid Oracle hostname
21/4/15 12:35:59.387 am java[815]: objc[815]: Class JavaLaunchHelper is implemented in both /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java and /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/lib/jli/./libjli.dylib. One of the two will be used. Which one is undefined.
21/4/15 12:36:17.015 am SonyAutoLauncher[436]: Enum Begin!
21/4/15 12:36:17.015 am SonyAutoLauncher[436]: Enum End!
21/4/15 12:36:17.015 am SonyAutoLauncher[436]: Enum Begin!
21/4/15 12:36:17.000 am kernel[0]: hfs: mounted Oracle Java 8 Update 45 on device disk4s1
21/4/15 12:36:17.064 am mds[56]: (Volume.Normal:2464) volume:0x7f9543881000 ********** Bootstrapped Creating a default store:1 SpotLoc:(null) SpotVerLoc:(null) occlude:0 /Volumes/A6C41DEC-149E-4397-80AE-658431B73334
21/4/15 12:36:17.126 am SonyAutoLauncher[436]: Device path: /Volumes/A6C41DEC-149E-4397-80AE-658431B73334
21/4/15 12:36:17.126 am SonyAutoLauncher[436]: Enum End!
21/4/15 12:36:18.265 am Java Updater[814]: App found:/Users/roy/Library/Application Support/Java/Java 1.8.45.14/JavaAppletPlugin.pkg
21/4/15 12:36:18.282 am mdworker[797]: (ImportBailout.Error:1325) Asked to exit for Diskarb
21/4/15 12:36:18.282 am mdworker[783]: (ImportBailout.Error:1325) Asked to exit for Diskarb
21/4/15 12:36:18.000 am kernel[0]: hfs: unmount initiated on Oracle Java 8 Update 45 on device disk4s1

Does anyone knows what's going on and how to fix it?

2

I just encountered this same problem: I don't know why it's happening but I was able to install the update by launching the downloaded package manually:

open "~/Library/Application Support/Java/Java 1.8.45.14 3/JavaAppletPlugin.pkg"

  • Works for me too. – resting Apr 21 '15 at 4:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .