12

In Mac OS X Yosemite, I find that the scroll bar is a small target for the mouse, and sometimes when I wish to scroll, I end up moving the whole window by grabbing its edge to the right of the scroll bar. This is never the behavior I desire.

How can I disable the ability to move a window by grabbing anything other than its title bar?

5
  • Why are you trying to grab the scroll bar as it shouldn't be necessary as long as the mouse is over any scrollable area of a window it should just scroll with a scrolling motion. Apr 20, 2015 at 2:06
  • 1
    @user3439894 I have those gestures turned off due to their being inadvertently invoked too often, so I need to grab the thumb to scroll the window.
    – WilliamKF
    Apr 20, 2015 at 2:29
  • 1
    Any luck? I have the same issue.
    – dvallejo
    Dec 14, 2016 at 5:15
  • @dvallejo Nope, I still face this issue, almost two years later.
    – WilliamKF
    Dec 16, 2016 at 18:39
  • 1
    Five years later (2020) and there is still no configuration, settings, or a solution to this.
    – jso
    Oct 9, 2020 at 10:52

2 Answers 2

1

I try scrolling with scroll bar because there is a scroll bar. Sometimes it's better than scrolling with mouse. (smooth scrolling)

To change, go to System Preferences: General settings -> Show scroll bars -> Always

1
  • 5
    This doesn't appear to answer the question.
    – WilliamKF
    Nov 11, 2015 at 22:30
1

Apple says this is by design. No use trying to complain about it. See an example post in their forum:

https://discussions.apple.com/thread/7491958

"It's not a bug but a deliberate design feature that was introduced a few versions of OS X ago." This reply is from years ago, already, so they do not intend to fix it at least for a while it seems.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .