3

I have MacBook Pro (Retina, 13-inch, Mid 2014) and also a third generation Apple TV. Lately, especially after 10.10.3 update for OS X Yosemite, I am having mirroring issues.

I have checked all the links, forums etc on google and still no luck.

The problem is basically, my ipad 2/iphone 5 can successfully mirror to Apple TV, but when I try to mirror my MBP, it only shows black screen with audio..

I cannot control the apple tv settings from my menu bar on MBP either. It does not let me choose whether to extend my desktop or mirror built-in display.

On web, I read forums with similar questions but they are generally left unanswered or did not work for me.

Thanks in advance xxx

  • what does it show as in your About this Mac? and how is the Mac connected to the TV. Also tell us with what screen resolution are you trying to use it. – Ruskes Apr 18 '15 at 21:12
  • My Mac resolution is 2560 x 1600 and tv is 1920x1080, i have connected with the same devices for many times before.. The connection is wireless however i have tried both ethernet and wireless with both devices to try to solve the issue – Bkdev32 Apr 18 '15 at 21:23
  • Is your Mac showing the TV ? since the Audio works you are connected but something is missing there. – Ruskes Apr 18 '15 at 21:30
  • Yes everything is working fine, I have the apple tv icon in my menubar and connection seems fine but the controls are disabled i cant click on anything in apple tv menu (menubar). But still no visual, i cant even stream purchased movies from itunes on my mac to apple tv, again black screen – Bkdev32 Apr 18 '15 at 21:44
  • Just a hunch, try to repair permissions in Disk Utility, or log in as different user. – Ruskes Apr 19 '15 at 0:17
0

In cases where something appears to work, but it is not following your commands:

  • Logging as different user and try again, to check if your profile/permissions needs repairs.
  • Open Disk Utility located in your utility folder, and use the Repair Permissions.
0

I had this problem with two teachers:

1) I un - replugged the ATV - that fixed the first one.

2) Other teacher was recently upgraded to MacBook Air, then it worked for about a week before getting black screen, but audio ok. She could get it to work from her iPad, iPhone, and I could get it to work from my MBPro.

For Teacher 2 I changed the resolution IN THE APPLE TV. Did not help to change resolution in computer until after I found that using 1080p HD - 50Hz (TV Resolution) from ATV Audio/Video from menu was the resolution that worked.

0

There seem to exist a multitude of possible reasons for this bug. Mine was having Duet Display installed. After some fruitless googling I followed a hunch and found this FAQ on their website:

Some customers are reporting issues with AirPlay when Duet is installed and they mirror or extend their desktop to an Apple TV. We have consulted with lead engineers on Apple's Airplay team and they are aware of the issue with 3rd party display applications but a fix does not seem likely in the foreseeable future.

So there's that. In case of Duet Display this means deinstalling the app. Simply quitting the app won't cut it. Fortunately they made it really easy and added a Deinstall option to the app menu. It's just too bad Duet and Airplay cannot co-exist.

EDIT: To extend on the symptoms I experienced, Airplay worked flawlessly out of iTunes. When activating Airplay mirroring or screen extension, the Apple TV only showed the black screen but played the mirrored audio.

-1

I was having this same issue. I just restarted my MBP and now AirPlay is working fine.

  • Welcome to Ask Different. While your answer may be correct, we like answers with more substance. Single line answers generally do not provide details, explanations, links or references. Please consider expanding on your answer to make it more helpful. apple.stackexchange.com/help/how-to-answer – Allan May 16 '16 at 0:14
-1

This answer works for me.

  1. Download and run uninstall for Air-Parrot http://support.airsquirrels.com/article.php?id=8

  2. Manually deleted the following files:

    APExtFramebuffer  located at: System/Library/Extensions
    AirParrotDriver   located at: System/Library/Extensions
    AirParrotDriver   located at: /Library/Extensions
    
  3. Restart

I found the answer here : https://discussions.apple.com/thread/5952624?tstart=0

  • The OP doesn't mention having AirParrot installed so how will this help? – fsb May 8 '17 at 14:44
  • It doesn't say the opposite either. I had uninstall AirParrot months ago but the extensions files was still present, I really think this answer can help people. – Gonzo Oin May 10 '17 at 16:13
  • I think it's best to stick with the info provided in the question. If you need additional info from the OP, please use the comments to clarify. Especially because this already had an accepted answer. Once you have sufficient reputation you’ll be able to add comments and ask follow-up questions. To gain reputation, answer questions that are clear and concise. – fsb May 10 '17 at 16:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .