2

Longtime macports user (tmux / 256color etc worked fine). Recently decided to switch over to homebrew. Have most things working again.

tmux throws the following error when launching (have not changed terminal or .tmux.conf)

open terminal failed: missing or unsuitable terminal: xterm-256color

I commented out the terminal settings in my tmux.conf and tried setting my $TERM to xterm. The same thing happens (replacing xterm-256color with whatever I have $TERM set to). My gut says that I was using a terminfo from macports and that I'm using the system terminfo with homebrew. Not sure how to do this with homebrew to test.

Possibly relevant versions numbers of stuff:

  • homebrew 0.9.5
  • tmux 1.9a
  • iterm 2.0.0.20150412
  • yosemite (up to date)
  • zsh 5.0.5
1

I had to add:

set-option -g default-terminal screen-256color

to my ~/.tmux.conf to get it to work under all the same versions you reference above on Yosemite. You can see my tmux configuration file here if you'd like a point of reference.

  • I've had that line in for ages. Tried taking it out to fix, didn't make a difference. – skarface Apr 18 '15 at 21:21
0

Rebooted to take an update, tried tmux again and things seemed to work. I'm guessing that logging out and logging back in would have fixed it as well. Probably needed to re-init the termcap after the macports->homebrew migration.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .