This is how it looks right now

This is how it looks right now

These are my "Language & Region" settings

These are my customization settings

There is clearly a bug involved. I don't want use an app to solve such ridiculously simple prolem. It should be reading this format from somewhere right?

  • What an amazing language calls a day of the week Pazartesi? I like it. Oh, Turkish. Cool. – Petruza Sep 12 '16 at 13:05
  • Anyone know how to get the date format mm/dd/yy? – JBis Jun 24 at 22:44
up vote 6 down vote accepted

I don't know whether you ever got the above method to work, but it never did the trick for me. However, I seem to have found a way that works without resorting to a 3rd party app. I was pulling my hair out about this because I wanted to have a '.' as the time separator, and even when using the defaults command like so:

defaults write com.apple.menuextra.clock "DateFormat" "EEE MMM d  H.mm"

It would successfully assign the value, but every time I killed the menu bar, it would inexplicably revert to the default format. I'm not sure how permanent this will be, but I did a quick loop in bash and after running it for a few seconds, I killed the menu bar from a separate shell, and then returned to the loop and killed it - voilà!

So, basically from shell 1:

while true;

    > do;
    > defaults write com.apple.menuextra.clock "DateFormat" "EEE MMM d  H.mm";
    > done;

...then in another shell:

killall -KILL SystemUIServer

And then return to the first shell and kill the loop. I haven't restarted yet, but so far the change has stuck. HTH!

  • Thank you! I wrote a little sh script to set my format, works like a charm. This is probably not gonna last, but it's something. – previous_developer Apr 28 '15 at 22:09
  • Here is the script: pastie.org/10119105 Can be killed with CTRL+C after you see your format on menu. – previous_developer Apr 28 '15 at 22:25
  • Right on! Glad it helped...this one was vexing me for quite some time. I can't get it to persist across reboots. Sometime, if I am motivated, I guess I can use init or launchd to set it every time it boots... – jet_atx Apr 29 '15 at 3:46
  • 1
    I recall this has worked for me in the past, but it's not working on a new macOS Sierra machine for me today. – Matt McClure Apr 4 '17 at 17:12
  • 1
    Confirmed. I'm currently working on dotfiles on High Sierra and this does not work. – slick Sep 3 at 5:07

There is a specific Pref Pane for the menu bar Clock settings, separate to the Dates pref, which is for how dates are shown in Finder.
System Prefs > Date & Time > Clock

You can also access it directly by clicking the menu bar Clock, or typing "date" into Prefs search

enter image description here

enter image description here

enter image description here

  • 1
    I actually want to put MY preffered format. These options are not enough. No year, no way to show month as number, etc.. This should be a pretty trivial task with terminal. I just don't know where to look. – previous_developer Apr 18 '15 at 19:15
  • Then you should ask that question separately. My answer simply points out that you were setting the wrong pref for the menu bar clock. – Tetsujin Apr 19 '15 at 11:18

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.