This dreaded issue started at some time after upgrade to OS X (Yosemite) 10.10.3. accountsd uses about 60% CPU constantly, making the laptop hot and noisy.

I'm not using iCloud at all.

Killing it doesn't help, because it starts again quickly.

Probably related question, but it's about iOS: iPhone: What is `accountsd` and why is it using 80% CPU?


You could try using the Console application to see if accountsd has recorded any errors. Just open Console and enter "accountsd" in the search filter in the top-right corner of the window.

accountsd doesn't just deal with iCloud accounts. It appears to handle all of the accounts listed in the "Internet Accounts" pane of System Preferences. You could try disabling them all, then enabling them one by one to see which one is causing the issue.

  • yeah, Console spams many messages, let me think about it for a minute Apr 17 '15 at 21:54
  • and it did contain the account name which caused problems. Problem is sort of solved, I'll accept the answer as soon as StackExchange permits. Apr 17 '15 at 21:56

In my case, a Gmail account password had changed (I had left a company but wanted to keep checking my mail in case of emergency.)

@Alistair's Console solution sorted me out right away.

The bigger mystery is why a borked account login needs to chew up 100% CPU (???), perhaps someone who works at infinite loop can enlighten us?

Wanders off, muttering to himself something incoherent about Apple developers


Check the console, in my case it showed the following:

23/05/2015 09:43:16.689 icbaccountsd[16967]: SOSCCThisDeviceIsInCircle SOSCCThisDeviceIsInCircle!! 329

I had Google Chrome open with Google+ running and it appears there's something polling related to adding people to circles. Quitting Chrome fixed it. I suspect restarting will fix it only for a while, though.


Date September 29, 2020 Catalina 10.15.7 installed

I had the same problem - noisy fan and very high cpu - 600+ - registered in Activity Monitor. The solution I have found is to disable 'commerce' in the activity window. 'commerce' is just that it seems - everything Apple does to 'smooth' purchases on its platforms. With commerce disabled, my iMac is running fine. Haven't restarted yet though so I imagine it will restart commerce so I'll need to disable it again. Needs an Apple fix.

Up date: I have now restarted and - yay! - so far no return to abnormal over use. 'commerce' is running again, too, as I expected - but all is - so far - fine

  • For me an update from 10.15.6 to 10.15.7 solved the issue. Oct 2 '20 at 11:31

My gmail account was also the culprit. It seems that around the Yosemite upgrade and/or adding my gmail credentials to iCloud keychain things got confused. I use 2-factor authentication on Google and had been using an app-specific password.

I ran the keychain access application, searched for "google" and "gmail" and deleted all the relevant entries. Yosemite then asked for my Google password, and I was able to authenticate with 2-factor rather than using app-specific passwords. Still had to set an app-specific password in the Mail preferences--not sure if that's intended. But all is well now.

Not the answer you're looking for? Browse other questions tagged .