1

Every time I insert an SD card or a drive via USB, dang Image Capture pushes its way to the front of my screen. This is just since the Yosemite update--I can no longer find an option to only launch this with certain SD Cards, etc. There's no eject button in the bottom left corner. I can't find any preferences or other features that would allow me to turn autorun off. It's not listed in my autorun programs in System Prefs.

Here's a screenshot of the guilty app: enter image description here

Appreciate any tips!

  • what is the Shared (1) you have showing ? – Ruskes Apr 17 '15 at 18:07
  • incidentally, what's "10.2.2, 2015" in your title? – Tetsujin Apr 17 '15 at 18:18
1

Plug in your device to your Mac. When Image Capture is open it should display the device that's plugged in. Select the device, then you’ll see, below the sidebar, an option allowing you to choose what happens when you connect the device.

screenshot

Click the menu that says Image Capture; you have several options, such as Image Capture, Preview, or, perhaps, other apps. But you can also choose No Application. Select that, and you’re good to go. In Image Capture, you can adjust this setting individually for each device.

If you don’t see the menu below the sidebar, click the little widget at the bottom-left of the window; that will display the menu.

Note: if you’ve turned on Photos in the Cloud in your iOS device settings, you won’t see this option, since your iOS device no longer lets you add photos to iPhoto when it’s connected. And you can’t delete photos from the device using Image Capture either.

  • James - thanks for the suggestion. Unfortunately the image I pasted in the original question is what shows when I insert a card. IC pops up but it's not even giving me the option to view the images on the SD card. The shared device listed is just my printer. I can see the SD card in Finder and interact with it find. But nothing to click on in IC and no way to select No Application. – Dave Wright Apr 18 '15 at 23:19
0

I have managed to make Image Capture never auto-launch, though I'm not quite certain how I did it.

I think it may be RCDefaultApp

In the Media tab I have simply set all options to 'Ignore' - even though there is no option for USB cards, they don't launch anything either now.

enter image description here

If it wasn't that, then perhaps it was that I disabled iTunesHelper from Login Items.

Whichever it was, I always now launch Image Capture when I like, not when it likes.

  • I tried disabling iTunesHelper and that did nothing. Was hoping for a fix without downloading another app, but it looks like i don't have a choice? I'll try out this RCDefaultApp. – Dave Wright Apr 18 '15 at 23:21
  • You'd have to reboot after disabling that from login items, of course - RCDefaultApp is just an interface to built-in functionality, btw – Tetsujin Apr 19 '15 at 7:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .