I've been texting my wife's number from this phone for months. Suddenly today I am getting an error message telling me I need to use a ten digit number. The number the error thinks I'm trying is my wife's number but with "11" added to the beginning.

So far I can still text other people without the error.

A similar error error has been reported before. One of the suggested fixes is deleting and recreating the contact and deleting all the texts, but I'd really like to avoid that if I can. I don't want to lose all of those texts.

I tried removing the "1" from the My Phone Number setting, turning MMS off and on, turning off dial assist, turning the phone on and off, manually deleting just her number and entering manually in a text message, and none of that has worked.

  • open contact and change the number for your wife's phone to read either "+1xxxyyyzzzz".or "xxxyyyzzzz" but don't use "1xxxyyyzzzz" (yes, in the first example I do mean put the character + at the beginning). Also can anyone else text your wife? Does she also have at&t or does she have another carrier? The error you are getting usually means the number is not textable.
    – Tyson
    Apr 17, 2015 at 16:51
  • I understand the setup is different in the US, but in the UK all numbers are 11 characters, or 10 plus country code. In any mobile/cell phone, you should be able to use 0123 456 7890 or +44 123 456 7890. The area code '0' always disappears if you add the country code. 0123 being the full area code, 44 is the UK international country code.
    – Tetsujin
    Apr 17, 2015 at 17:19
  • Since he said the carrier AT&T I assume he's USA. (As an added bonus I also have AT&T myself). In reality whether he puts +1, 1, or none in front of the 10 digit number it should work. In the question that you linked above I was able to duplicate the behavior exactly. What's odd in this case is that it's his wife number so you would think he would be aware if her phone was out of service, but the behavior leads one to believe that the wifes phone is out of service. Not out of a service area, but disconnected or number changed type of out of service.
    – Tyson
    Apr 17, 2015 at 17:44
  • Others can text her just fine. I am in the US. I tried removing the 1 from her number in my contacts but it didn't change anything. I also tried adding +1 to her number and the same error resulted.
    – user800268
    Apr 17, 2015 at 19:44

1 Answer 1


I just fixed this after 2 years. First- delete the contact altogether. Second - delete every single message the person has ever sent you, including any group texts they are in (if it's not obvious to you, search for their name, and when the messages come up, swipe left on them and hit delete). Third- re-enter their contact, being sure that there is a 1(xxx)xxx-xxxx format and that the selected type of number is iPhone (even if it Is not).

Send a test message. If it doesn't work, do a reset and do it all again. If you don't delete every single old message, it won't work. It worked for me!!

I have no idea what the original problem was because I share contacts with my husband and he could text these two contacts. I just know this worked. Apple tech even said she was going to write it down to share because she had no idea.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .