2

Sometimes on OS X Yosemite my connection to a shared network server is stick connecting, while the server is available. OS X simply won't connect to it using Finder and the Connect As... button doesn't respond. It won't eject either. Only a restart fixes everything again, a relaunch of Finder doesn't help. I am wondering if there's a fix or easier workaround for this.

Visual example

Edit: I'm not even sure it can connect to any shared computer at all when this happens and it seems Finderaccess is fully broken.

Update: I'm going to try a few other methods to connect to the server found on http://www.macworld.com/article/2012153/eight-ways-to-connect-to-a-server.html whenever the issue reoccurs.

Update: I found that the process that (I guess) arranges the connection from OS X to the server using SMB hogs up a lot of memory. The command of the process is /usr/local/sbin/smbd -D -s /usr/local/etc/smb.conf. Killing it on the server remounts the drive on OS X and makes the slowness disappear. On another note: OS X also often mounts multiple instances of the server, appended with -1, -2 etc. I'm still not sure what causes the issue, but at least I have a quicker fix than a reboot.

  • 1
    What OS on the remote machines? What protocol? AFP, SMB…? – Tetsujin Apr 17 '15 at 8:22
  • FreeBSD / SMB. Your comment already helped me a bit while searching for answers to your questions, as I could try to connect using CMD + K when the issue occurs again – Tum Apr 17 '15 at 8:34
  • Not sure on BSD, but I know that with Windows over SMB, often a Mac can force a master browser election & win it, even when it shouldn't, which messes up sharing until the correct machine can get back master browser status. I force one [Windows] machine in my network to always win the election; fixed a lot of similar 'weirdness' – Tetsujin Apr 17 '15 at 8:37
  • Does that mess up other computer's connection with the server as well, or do those issues only apply to the Mac causing the issue? As others (both Macs and PC's) can connect to the server just fine while the problem occurs. – Tum Apr 17 '15 at 8:41
  • 1
    Seems very helpful, will try those settings as well. I'll update whenever I'm able to try to apply these methods. – Tum Apr 17 '15 at 8:57
1

I was having the exact same issue. In my case, both my mac and my nas were configured for jumbo frames. My new switch, however, even thought it supports jumbo frames, did not have jumbo frame support turned on. Knocking the MTU on the mac back down to the standard 1500 MTU (under advanced settings, and the advanced tab in network system preferences) got everything working again.

  • Swapped old Netgear router for new one. NAS appeared in finder sidebar; shares showed up, but trying to open one gave the spinning wheel and no contents ever appeared. Couldn't then disconnect; shutdowns required force-quitting Finder. Changed MTU back to 1500 from 9000, and everything worked! (Old router was WNDR3700, new is R6700. Apparently old one handled jumbo frames better!) – Adam Wilt Sep 10 '17 at 5:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .