2

My MacBook Pro (mid 2012) was encrypted and running Yosemite 10.10.3. (The last update with Photos ruined it.) Yesterday, all of a sudden, everything freezes. I forced Shut Down and since then, it´s all gone.

I've tried every single possibility that I could find in apple support discussions forums. Tried to verify, repair, erase and partitioning the HDD and I just can't. The only possible way to boot my Mac is through Internet Recovery (cmd+R, because there´s no Recovery HD left). I tried to erase the HDD through Terminal, with diskutil eraseDisk JHFS+ MacintoshHD /dev/disk1*.

*Sometimes the HDD I want to fix is disk0, others disk1...WTF!?

I had no success. I tried to partition it without success. When I try to re-install the OS or restore from Time Machine, the hard disk doesn't appear. It's like it isn't mounted.

Is there a way to solve this without buying a new hard disk? I don't mind going extreme, because I have backups. Is it possible it is something related with the fact that it was encrypted?

UPDATE: I tried every single possibility I could reach (e.g. GParted, TestDisk, tons of different command lines on Terminal, boot from USB, from CD). It seems to be dead.

Some brief example of errors

diskutil repairDisk /dev/disk0
Nonexistent, unknown, or damaged partition map scheme
If you are sure this disk contains a (damaged) APM, MBR, or GPT partition map, you can hereby try to repair it enough to be recognized as a map; another "diskutil repairDisk /dev/disk0" > might then be necessary for further repairs
Proceed? (y/N) y
Error repairing map: MediaKit reports bad partition or no map found (-5324)

diskutil eraseDisk JHFS+
New /dev/disk0 Started erase on disk0
Unmounting disk Error: -69825: Wiping volume data to prevent future accidental probing failed

  • Using Internet Recovery you can first unlock that drive. – Ruskes Apr 15 '15 at 23:11
  • The drive is not locked anymore, because I tried to erase the disk. It couldn't erase properly (I got some error messages), but removed everything. My point is: is there something that could be left from the encryption process that makes the disk not format and partition properly? – Mohr Apr 16 '15 at 15:01
  • do you have USB with OSX on it ? to start from and possibly take care of that drive! – Ruskes Apr 16 '15 at 15:49
  • Please read this article cnet.com/news/tackle-stubborn-disk-partitioning-in-os-x – Ruskes Apr 16 '15 at 16:01
  • Yeah, I tried to boot from USB with Yosemite on it. Still, not able to format the internal Hard Drive. Always get some errors. – Mohr Apr 17 '15 at 15:25
2

This sounds like your hard drive failed entirely. I see that it's a typical SATA drive in that model. You should be able to open it up and remove the drive, then wire the drive to a desktop and see if it is detected. If it is not, that confirms that the hardware failed.


Comment by OP: It turned out to be a SATA cable failure, see Hard Drive Issues with MacBook Pro 13-inch mid-2012.

  • The Hard Drive is detected, but I cant erase or partition it properly. I´ll be doing this later today. I dont have a desktop anymore – Mohr Apr 17 '15 at 15:26
  • You say your HD is detected. Is that in DiskUtility? If so, can you see both the drive and the volume? You must run partitioning from the drive, not the volume. Also, see if the drive is mounted -- select the drive, see the mount status in the DU menu bar. I think you can tell if the volume is mounted if the volume is greyed out. If it's mounted, unmount it, and try portion/reformat on the drive. It does sound like your Drive has failed. – David DelMonte Apr 17 '15 at 16:22
  • Yes it is in DU. Sometimes the Drive (APPLEHD750GB...., something like that), and sometimes it has a volume that is impossible to mount or repair(disk1s2). – Mohr Apr 17 '15 at 17:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .