2

I have a Mac which was reinstalled from scratch, and the owner accidentally changed her username when installing it. Current user id is "Jane" but old time machine backups were made when her user name was "Jan".

Now, she can't access her old backups.

The obvious solution is to go onto her backup drive and change the ownership of the hierarchy from "Jan" to "Jane" but every time I try, I hit the "operation not permitted" wall. I tried fixing the ACLs before executing "chown", but I get "operation not permitted" for that as well:

$ sudo su
# cd /Volumes/SeagateBackupDrive
# cd Backups.backupdb
# ls -led .
drwxr-xr-x@ 8 root  _unknown  272 Sep 20  2014 .
 0: group:everyone deny add_file,delete,add_subdirectory,delete_child,writeattr,writeextattr,chown
# chmod -a "everyone deny chown" .

# cd "Jane's MacbookPro"
# ls -led .
drwxr-xr-x@ 5 root  _unknown  170 Feb 14 16:03 .
 0: group:everyone deny add_file,delete,add_subdirectory,delete_child,writeattr,writeextattr,chown
# chmod -a "everyone deny chown" .
chmod: Failed to set ACL on file '.': Operation not permitted

I've tried all sorts of things like modifying the "writeattr" permission or looking for the uchg flag, but so far no luck.

This is on a Snow Leopard machine.

  • I ran in to a similar problem a while back. Can't remember exactly what I did but have you tried moving/copying the backup out of the Backups.backupdb folder, setting the permissions, and then moving it back in again? IIRC, that's how I sorted my problem. – Stuart H Apr 15 '15 at 19:24
  • I remember the good old days when being root was carte blanche "do what I say". – Edward Falk Apr 15 '15 at 20:42
  • I don't have the full answer yet, but I think it's a matter of using sudo chmod -N -R . to remove the ACLs from all the files and sudo chflags -R nouchg . to clear the immutable flag – Edward Falk Jul 24 '16 at 21:43
  • 1
    You need to match the user ids and not necessarily the names – Mark Aug 20 '16 at 21:30

You must log in to answer this question.

Browse other questions tagged .