I'm trying to install OS X Yosemite through 'Install OS X Yosemite.app' downloaded from the Internet. When I try to open it by double clicking it, nothing happens. When I use the terminal I get the following message:

$ open /Applications/Install\ OS\ X\ Yosemite.app/
LSOpenURLsWithRole() failed with error -10810 for the file /Applications/Install OS X Yosemite.app.
  • Install on to what ?
    – Ruskes
    Apr 15, 2015 at 15:15

7 Answers 7


That would seem to imply the executable within the package isn't actually executable.

Where did you get it from?
If not Apple, I'd leave it well alone. If it was from Apple, try this in Terminal

chmod +x /Applications/Install\ OS\ X\ Yosemite.app/Contents/MacOS/InstallAssistant

  • 2
    This helped me, but I just wanted to add that I fixed my problem (running Kettle Pentaho 4.4 on OS X Yosemite) by making the same permissions change to Contents/MacOS/JavaApplicationStub in my .app directory.
    – Matt Vukas
    Aug 26, 2015 at 18:46
  • Add that as another answer - it may be helpful for future Googlers
    – Tetsujin
    Aug 26, 2015 at 18:56

I had this error with Pentaho 8. This command solved it for me: xattr -dr com.apple.quarantine '/Applications/Pentaho/design-tools/data-integration/Data Integration.app'

OSX will "quarantine" files that are downloaded from untrusted sources.

You can see if this is your problem by listing the xattrs. cd /path/to/your/ApplicationName.app xattr -l Contents/MacOS/*

If you see "com.apple.quarantine" then that's your problem.

  • 2
    Thanks, this fixed my issue with Pentaho Data Integration not starting on macOS as well.
    – Tharabas
    Jan 31, 2019 at 12:03
  • 2
    I thought this might solve my problem with Wings3D 2.1.7, because it did indeed have a "com.apple.quarantine" xattr attribute set, but even after removing the attribute, while the actual executable file can be run, running "open" on the .app package still gives the "-10810" error (similar to what @tripleee describes in their answer).
    – Jacob C.
    Apr 2, 2019 at 21:39

I mysteriously got this on Yosemite for the Calendar app. Launching the actual binary worked for me.

bash$ /Applications/Calendar.app/Contents/MacOS/Calendar &

There did not seem to be a permissions issue that could be fixed with chmod.

The symptom I got originally was "The application "Calendar.app" is not open anymore" when attempting to click calendar reservations in Mail.app.

  • I had this problem with Pentaho and had to run "xattr -d com.apple.quarantine JavaApplicationStub" on the internal binary to get it to work. Dec 13, 2017 at 20:26
  • You mean the path I show in the answer? Mine doesn't have any xattr but it's still misbehaving (now worse than when I posted this answer).
    – tripleee
    Dec 14, 2017 at 4:23
  • FWIW some update along the way revived my Calendar and it's now back to normal, I think after 10.13.3 or 10.13.4 High Sierra update.
    – tripleee
    Apr 11, 2018 at 7:43
  • Thanks, this helped me get to the bottom of my problem. Once I tried to run the binary directly I got the message '2022-02-16 11:34:06.010 someapp The application with bundle ID XYZ is running setugid(), which is not allowed. Exiting.' which makes sense as I had set the setuid bit previously.
    – We'll See
    Feb 16, 2022 at 11:57

I had this error when attempting to run an application from an ssh terminal while the screen was locked. The app complained that the user did not have permission to open a GCWindow.

Unlock the screen by logging in, and my app now launches fine.


As commented by @Matt Vukas in the currently accepted answer, it appears that a good thing to check might be simply changing the permissions of the file that gets executed within the .app directory.

# Note: change YourApp to the app name (in both places!)
chmod +x path/to/YourApp.app/Contents/MacOS/YourApp

This command worked for me with a MacOS build that was exported from Unity (the game development engine).


I got the same error when trying to run an app on my system. Following the @tripleee answer (trying to launch the app's binary) gave me a more instructive message:

wsee$ cd /Applications/someapp/Contents/MacOS
wsee$ ./someapp
2022-02-16 11:34:06.010 someapp The application with bundle ID XYZ is running setugid() which is not allowed. Exiting.

Sure enough, when I checked the setuid bit was set (bolded in example below):

wsee$ ls -l
drw**s**r-xr-x@ 3 wsee  staff         96 12 Jul  2021 someapp

When an executable has its setuid bit set then it will be run as the file owner no matter which user launches it. In the above example, if user Bob launches someapp then it will run with the effective user id of 'wsee' even though it is Bob running the app.

Setuid (aka set-user-ID-on-execution and SUID) presents a serious security risk when used on executables owned by root, because if a vulnerability exists in the executable then an attacker might be able to execute code as root, giving them limitless control over the system.

Removing the setuid bit was a simple matter of running: chmod u-s someapp


What helped me with this error message under macOS Mojave 10.14.6 was to move the .app file from the Downloads directory to the /Applications directory.

Then I could start the .app file without problems.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .