3

Suddenly my iPhone won't let me add new events to my calendar. In the upper right hand corner of the 'month' calendar there are 3 symbols.

  1. A rectangular box with 2 lines underneath.
  2. A magnify glass.
  3. A '+' The first two are red and active The third one is gray and inactive.

I've read solutions to problems from others, but nothing has helped. I also have and iPad, and the calendar on it works fine. I have compared settings on both products, and they seem to be set the same way.

  • 1
    Could you add if your iPhone and iPad are synchronizing on iCloud? – daniel Azuelos Sep 18 '15 at 19:15
2

I had the same problem, went into the calendar, tapped on "Calendars" in the bottom center, here there were two calendars listed - holidays, and birthdays. I pulled down on these items (like scrolling, the screen refreshed then showed 5 calendars. From some reason I-cloud was not selected, I selected this and all the calendars listed became active.

I went back to the calendar view (by month) and am now able to add events.

BTW, none of the other options I have tried worked, only this method. Under general settings both my iCloud and Yahoo calendars were active, but under the actual program they were not. Don't waste your time in the general settings change it from the program.

1

Go into settings, scroll down to iCloud, make sure iCloud is "On" (or "green") for Calendars. As soon as I turned this on, I was able to create events again. The "+" sign was no longer gray, and it was red and active again.

0

On my 5s when the above answer didn't help solve that when I created a new event on my calendar and pressed Add, it didn't register. I discovered it was actually created but was invisible. To rectify this problem, I went to the Calendars button on the tab bar (when calendar is open). At the top is a button titled either, "Hide all calendars" or "Show all calendars". Since you want all of your calendars to show, toggle it so that what you see is "Hide all calendars". This will then show all of your calendars and the events you've created.

  • This isn't exactly the same problem as the original one: your + button is active. – daniel Azuelos Sep 18 '15 at 19:18
-1

I had the same problem on my Iphone 5c. I went to the plus sign like I was going to add a new event. The scrolled down to where it says 'calendar." Nextto it was the word home. I cicked the arrow and it gave me the option to choose "calendar." I did and it is now adding the events to my calendar, but I have to choose it every time. I need to figure out how to make it permanent so every event is added without me having to change that setting each time.

Hope this helps you!

-1

Went to calendar like that person said earlier, at the bottom of the page between "today" and "inbox" - check all iCloud and it fixes the problem.

-1

Below steps solved my problem.

  1. go to calendar app.
  2. At bottom click "Calendar"
  3. At top "Make it Show all Calendars"

You must log in to answer this question.

protected by Community Mar 24 '16 at 14:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .