7

I am trying to reset my admin password using recovery partition. When I type resetpassword in terminal, a window shows up but I don't see my drive in the top box.

enter image description here

Is there a way to fix this? btw, I tried booting into single user mode, but it goes straight to the login page.

EDIT:

I may know why the drive doesn't show up. I checked Disk Utility and saw that the drive is locked. But I need a password to unlock it, which I don't have!

7

The drive is locked using FileVault encryption and cannot be accessed until you unlock the drive. This may be set to a master password of yours, and often is set a while back. You may want to try older passwords (or versions of them) to see if any of those work.

To unlock the drive:

  1. Boot into the recovery mode
  2. Launch Disk Utility
  3. Select the drive in disk utility
  4. Click unlock near the top of the disk utility window

Unfortunately, the drive will not allow you to boot into those options and/or work on it until you pass the encryption lock. It will require a password or for you to completely erase the drive.

  • So this won't work without having the password. – AliBZ Apr 14 '15 at 18:52
  • 1
    Correct. My steps only address the solution to the original problem, which is the drive not showing on the screen and the reason why the drive is locked. Beyond that, I cannot offer help for determining a lost filevault password beyond wiping the drive. – smoooosher Apr 14 '15 at 18:54
  • 2
    @AliBZ If you don't have a valid password or the FileVault recovery key (or have stored the key with Apple), there's no way to get at the data on your hard disk. That's pretty much the purpose of FileVault. – Gordon Davisson Apr 14 '15 at 19:39
-2

For my problem, I tried the 'Boot into Recovery Partition' method and unlocked the volume because it was locked with FileVault password and fortunately I had saved the Filevault password. Here is the article with the steps I followed: https://iguruservices.com/support/reset-mac-admin-password/

It opened the disk utility first and unlock the disk and then opened terminal and type command resetpassword to change my admin password.

  • While this may answer the question, it's better to include the relevant details within the answer itself. Links to external sites often go stale making the answer useless. See How to Write a Good Answer in the Help Center for more information. – Allan Feb 11 '18 at 20:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .