12

Is it possible to run Adobe Illustrator CS6 with the current Oracle Java 8 rather than the legacy insecure Java 6 provided by Apple?

I know this is related to this question where the generic answer was that it may be incompatible, but I'd like to know if there is some shady hack that makes it run anyway.

  • The only solution that worked for me on my Sierra machines using CS5 was the answer from Zac Jackson above. Just be sure to re-enable SIP in terminal from recovery mode afterward. – keeter Mar 5 '17 at 16:25
10

To activate Illustrator CS6 on El Capitan, you may need to temporarily deactivate the "rootless" mode. To do this, boot into the recovery partition by holding down Cmd-R upon startup. Then use the terminal app to disable "rootless". The command is

csrutil disable

It will advise you to reboot. After rebooting, you can now create the directories

/System/Library/Java/JavaVirtualMachines/1.6.0.jdk

and

/System/Library/Java/Support/Deploy.bundle

Then you may reboot back into recovery mode, and run

csrutil enable

to reactivate the "rootless" mode.

  • 1
    This was the only answer that worked for me on El Capitan. Only these two directories are needed for CS6 to launch successfully. – Nick Farina Nov 10 '15 at 22:54
  • I didn't even need to install CS6. I only needed to create these directories. – Merchako Dec 27 '16 at 21:27
6

On my Mac, the creation of these directories

sudo mkdir /System/Library/Java/JavaVirtualMachines/1.6.0.jdk
sudo ln -s '/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents' /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents
sudo mkdir /System/Library/Java/Support/Deploy.bundle

alone allow me to run Illustrator CS 6 even when neither Java 6 nor Java 8 is installed. Apparently, Illustrator only checks for the presence of these directories to determine whether Java is installed (it actually launches even when java itself is absent, provided directories above are created). I would like to know, which functionality in Illustrator CS 6 actually requires Java, as it apparently can launch without it.

Note: On OS X 10.11 and later you'll need to disable System Integrity Protection from the Recovery HD using csrutil disable in Terminal. Have a look at: About System Integrity Protection on your Mac & How to Disable System Integrity Protection (rootless) in OS X El Capitan.

  • I would be curious to know whether Illustrator is actually using Java 8, or just not using Java at all. This would probably require figuring out what Illustrator functions actually rely on Java in the first place... – Wowfunhappy Nov 15 '18 at 3:29
2

After some experimenting, I found a working solution based on this discussion.

  • Create a directory /System/Library/Java/JavaVirtualMachines/1.6.0.jdk.
  • Create a symlink /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents to /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents from Java 8.
  • If missing, create an empty directory /System/Library/Java/Support/Deploy.bundle.

You'll probably need to be root to do this, so use sudo using an administrative account (consult an expert if you are inexperienced, use at your own risk):

sudo mkdir /System/Library/Java/JavaVirtualMachines/1.6.0.jdk
sudo ln -s '/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents' /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents
sudo mkdir /System/Library/Java/Support/Deploy.bundle

You can ignore errors stating that something already exists.

2

Just had to overcome this issue on mac os 10.12 Sierra. Then basically follow @Zac Jackson's guideline. Install java8 as supported on sierra (ie from oracle). The rest happens within recovery mode:

Boot into the recovery partition by holding down Cmd-R upon startup. Then in the terminal app to disable "rootless", ie "System Integrity Protection":

csrutil disable

Create the directories:

 mkdir /Volumes/Macintosh\ HD/System/Library/Java/JavaVirtualMachines/1.6.0.jdk
 mkdir /Volumes/Macintosh\ HD/System/Library/Java/Support/Deploy.bundle

Then reenable "rootless":

 csrutil enable

Restart and Illustrator should be fine....

0

Verified the last answer as a fix for the following: Dreamweaver 5.5 Illustrator 5.1 <- crashes on exit Bridge 5.1 Extension Manager CS5.5 Fireworks 5.1 Media Encoder 5.5 Media Player

Adobe Flash CS5.5, Adobe Flash Catalyst, and Adobe Flash Builder 4.5 all crash on launch with JVM errors.

This answers the question above concerning why Illustrator and other Creative Suite apps check for Java machine compatibility since all the Creative Suite products are supposed to be interoperable. For example, you are supposed to be able to launch Flash from Dreamweaver in order to insert a Flash object into a web page.

Additional details: Upgraded to El Capitan last night. using the Java 8 as provided by upgrade. I did not try to test Java in any browser yet.

Important note: The above instructions assume you know that you know you are supposed to be operating on your System Volume and where it is. When you boot up with Cmd-R you will boot into the recovery partition. When you open Terminal you will be in the recovery partition. In order to get to the partition of your hard drive where your system volume is you must enter 'cd ..' a few times till you are at the top of the file tree then 'cd Volumes' and then 'cd [Your boot drive name]'. Then the directions above will accomplish what you want. I have yet to try the symlink solution because it doesn't seem applicable to El Capitan. [edit] In my first response I found that carrying out the fix suggested by archemdix and that solved the problem for most of the CS5.5 bundle. I apologize for the duplicate posts. I realized after a little research that when El Capitan wiped out the old Java and installed the newest version of the java runtime, it did not install the JDK. If you have just upgraded to El Capitan and you see the message "It appears you do not have a Java Runtime installed" when checking in Terminal with "java -version". I guess Apple figures developers are smart enough to figure this out. But after having Sun and then Oracle look after my Java updates for over a decade, it wasn't an intuitive change.

  • I've removed the duplicated paragraphs but it still is a bit difficult to read and understand. There is no such thing like "last answer" on this site, so please reference the answer you had in mind. Also right now, it's a bit unclear whether you are providing an answer to the problem stated in the question or whether your post is more kind of a comment to existing answers. Can you please clarify? – nohillside Oct 27 '15 at 9:34
  • I hope I've made my answer more clear. Please let me know. – BrianDSy Nov 11 '15 at 7:24
  • Thanks for coming back. Your answer still seems to refer to/comment on one of the other answers, without really making it clear which one. The goal on AD is to have answers which stand on their own (think of yours being the only answer -> what should be added to make it complete). If you rather want to add some details/explanations to one of the other answers, you can (and are invited to) edit them directly (there is a 'edit' link at the bottom of each answer). If you rather want me to do it, please at least indicate which answer you are extending with your contribution. – nohillside Nov 11 '15 at 9:40
0

I got AI to run by first installing the Apple-distributed Java ("javaforosx.dmg"); then installing (updating to) the latest version of Java. I don't have time (or the inclination) to test the other CS6 or CS5.5 apps, but this did the job for me. I don't know what I'll do, if I forget not to "downgrade" to any future version of OS X.

0

In my case (MacOS Mojave, 2014 MBA), I could just reinstall java6 using homebrew with no other changes at all (didn't disable SIP, didn't create directories, didn't even restart):

brew cask reinstall java6

Took a long time to install and seemed frozen at one point, but be patient :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .