8

I added a new gmail account to Mac Mail via the File> Add Account, but the mailbox does not show up in mail.

If I try to add it again, it says the account already exists. It does exist in System Preferences > Internet Accounts, but does not exist in Mail.

I am updated to 10.10.3 and Mail.app is Version 8.2 (2098)

Anyone have a fix?

  • Are you on 10.9.2? What version of Mail.app? What happens when you go to system preferences internet accounts and remove the affected account details? – bmike Apr 13 '15 at 20:57
  • I'm on OSX 10.10.3, Mail Version 8.2. When I remove it from Internet Accounts, and try to add it back again, it says the account already exists. Then if I restart my computer, it shows up in Internet Accounts again. – jetlej Apr 13 '15 at 20:58
  • Ugh - this is going to be messy. You might want to first make a brand new user account on the Mac and test that it can add that account properly. From there, check google's settings to see if you have app specific passwords or two factor auth enabled. Once you've narrowed this down to a user account corruption and/or server problem you'll have a far shorter list of things to try... – bmike Apr 13 '15 at 21:00
  • I'm on that same version of Mail and I don't see File>Add Account. Have you tried Mail > Preferences > Accounts > and then clicking the "+" to add the account? – dwightk Apr 13 '15 at 21:03
  • @dwightk - Yes I've tried both. – jetlej Apr 13 '15 at 21:09

15 Answers 15

8

Yes - this can be caused by three things. iCloud being messed up (and trying to sync your internet accounts) and corruption on the Mail settings and corruption in general in your user settings.

To troubleshoot this:

A. Write down your add/remove procedure and don't deviate from it. My guess is it should be:

  1. Quit Mail and make sure it doesn't launch when you log in
  2. Remove the account from system prefs
  3. Reboot
  4. Add the account in - optionally test something other than mail first like a bogus calendar entry to check the account and google servers.
  5. Test Mail by enabling the account and then finally launching Mail

B. Set up a brand new user account - with no iCloud and no Apple ID. Try adding the mail account there from System Preferences - Internet Accounts Preference Pane

If that doesn't work - your gmail is messed up or you need to reinstall the Mac from scratch (i.e. something is really wrong with the OS - this would be my last resort - make sure Gmail settings are clear at that point before backing up and wiping the Mac)

C. Sign out of iCloud on your Mac with your normal account.

Get a good backup before you delete content on the Mac. You will want to delete anything that's synced to iCloud to let the system clear out data that depends on iCloud. If you're paranoid, export data like Contacts and Calendar to a stand alone export/backup before you take this step. Then repeat the remove/add procedure.

D. Go to the logs. You'll need to run sysdiagnose Mail and then get into Console app and perhaps Log Connection Activity by opening the Mail Connection Doctor and checking that option.

enter image description here

| improve this answer | |
  • I had the same problem and part A fixed it. It took hours, though – if you have the connection log open (as explained in part D) you can see it downloading every single email. When it had eventually finished I clicked on the account and got the spinning beach ball which didn’t go away. It seems to be OK now following a restart although the Activity window is showing lots of syncing is still going on very slowly, including caching 273 attachments at the rate of one every 5 minutes or so… – user535673 Apr 26 '15 at 8:35
  • @user535673 I think Mail goes too far to hide bad mail connections. I'd love it if you could look at requests in bulk - knowing that 10% of the requests to the server fail over a day's period or knowing how long actions take would go a long way to firing a bad mail provider and hiring a better one. As it is, mail keeps trying valiantly in the background but doesn't log statistics to identify problematic issues on the server or network side. – bmike Dec 29 '15 at 17:02
3

For me the problem turned out to be simpler. "Mail" was not enabled for my Google account. To fix it:

  • Open System Preferences
  • Go to Internet Accounts
  • Check your Google account. Make sure that "Mail" is enabled.
| improve this answer | |
2

I had exactly the same problem with my Mail (8.2 (2098)). I think that the problem was caused by the fact that I was living in China, so the Great Firewall blocked (almost) all Google-related connections. I had to use VPN-connection to access Gmail.

I tried your methods without success. Nevertheless, I found out that Google was actually blocking the Mail connection attemps so I had to "unblock" it by the next easy steps:

  1. Start the browser on your device

  2. Sign in to Gmail

  3. Go here: https://accounts.google.com/b/0/DisplayUnlockCaptcha - press Continue

  4. Go back to your client and try the failed operation again.

I hope this was helpful.

| improve this answer | |
  • Even from non-chinese dudes / no firewall problem, your Google link worked like a charm to "unlock" my google. – Ninsuo Oct 11 '15 at 17:55
2

I read the other responses, they didn't work for me (and I don't want to log out of Icloud because that's a time waster). This is the way I fixed it:

  1. Create a mail alias (you can find this in settings of outlook.com or gmail)
  2. Use this alias to log in
  3. Go to settings and set the alias to your original settings apple mail
  4. Stop wasting time on this unprofessional bug of apple
| improve this answer | |
1

Go to System Preferences and then Internet Accounts and tick off Mail. This would work in the case that: you already have the account set up, but have Mail disabled on it. (For instance, you may have only Calendar and Contacts sync enabled on it currently).

| improve this answer | |
  • 1
    We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed. – Tetsujin Oct 17 '15 at 13:16
0

I was struggling with this and tried all of the other answers.

On closer inspection in the Accounts list I found that during my El Capitan upgrade the installer had renamed one of my email accounts to be the same as another (I missed this in my list of a dozen or so accounts), and disabled the account. It was the account that El Capitan said already existed.

I simply correctly renamed the account and re-enabled it. (And then had to go fix all of the many rules referencing the account and its mailboxes).

| improve this answer | |
0

My version of this issue is that: - my apple or iCloud id is user@gmail.com - the email account I'm trying to add is also user@gmail.com

Here's what works for me: - remove iCloud account - add my gmail account - add iCloud account

Seems like this may be a bug with Apple's "internet account" software.

| improve this answer | |
0

I did the following and it worked: I put in a wrong password, the whole info came up, put in the right password, and voila

| improve this answer | |
0

I tried many solutions, however the only thing that solved my issue was to add my gmail account using "Add Other Account..." with incoming server "pop.gmail.com" and outgoing server "smtp.gmail.com"... instead of clicking on the Google logo for adding an "Internet Account" in OSX.

| improve this answer | |
0

I had a related problem: I changed the password on my Google accounts, and discovered that I couldn't get Apple Mail/Internet Accounts to update -- I'd enter the new password but get the "account already exists" error message. The solution turned out to be easy. I went into my Keychains, looked for everything with "google" in it, and removed them all. Some of them were more than two years old, and I've changed my Google password several times in that period. Once that was clean, I was able to set up Google anew in the Internet Accounts section and everything synced.

| improve this answer | |
0

I have had the same problem on my new MacAir running 10.11.3, for both yahoo & Gmail.

For me it was solved by simply un-ticking & then re-ticking the mail option for both accounts -> Internet Accounts -> System Preferences. Both accounts then appeared in the Mail app and emails very quickly started to sync.

| improve this answer | |
0

I found a solution that worked for me and was pretty quick and easy. It's posted over here: http://disq.us/p/1docj72 It basically asserts that the iCloud is conflicting with the account, so you log out of iCloud, then enter the passwords, then log back in. iCloud will scare you (maybe rightfully so) by warning you that it will delete all your data when you log out - seems insane, doesn't it! But, when you log back in, it will restore all that data (caveat, I don't use iCloud for much of my data, so you probably want to be sure to have a back up, just in case - TimeMachine will probably do)

| improve this answer | |
0

I did not have to delete my iCloud account and it turned out the answer was very simple. When you are in accounts, and it wants you to enter "Outgoing SMTP account" enter the name of the account that you already set up with the SMTP information. The User Name, Password, Host name, Port and authentication will automatically be entered. Press save.

| improve this answer | |
0

Open System Preferences, click on Internet Accounts and Google (mail), then you see some checkbox so click on Mail app. Then you will easily be able to login.

| improve this answer | |
-1

This helped me (and prevented me from doing a complete wipe out of my mac) : https://discussions.apple.com/thread/7260368?start=0&tstart=0

| improve this answer | |
  • Welcome to Ask Different! We're trying to find the best answers and those answers will provide info as to why they're the best. Explain why you think the link you provided will answer the question. Links can change and become outdated so we prefer the answers to not just be a link. See How to Answer on how to provide a quality answer. – fsb Nov 15 '16 at 19:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .