17

I am using an EU keyboard layout and the button below the ESC key is "double quotes" on OSX 10.10.3

Suddenly that key is automatically changed to the < >| key

I checked keyboard layout and it is correct.

I think the keyboard assistant (which asks you to press the button near the left shift) can solve this issue, but I can't find that utility. System Preferences > Keyboard no longer shows Change Keyboard Type.

How can I find/open that Keyboard Assistant or make that Change Keyboard Type button appear again?

4
  • What is your keyboard layout name? By "EU" do you mean "US", where the US flag would normally show at the top right of the screen. Commented Apr 13, 2015 at 12:37
  • 1
    See if anything on this page helps: m10lmac.blogspot.com/2009/12/fixing-keyboard-type-problems.html Commented Apr 13, 2015 at 12:38
  • Thank you. You showed me the way. Deleting plist file let me open the Keyboard Assistant but it couldn't detect the correct "type" (where the left shift is narrow). So I requested plist file from my friend and used it. It solved the problem!
    – frankish
    Commented Apr 13, 2015 at 13:35
  • Good news! I am still curious what keyboard layout you are using -- I'm not familiar with one which has quotes on that key. Commented Apr 13, 2015 at 15:33

3 Answers 3

2

You might be able to launch Keyboard Setup Assistant manually, if the 'Change Keyboard Type' button is missing..

It's in /System/Library/CoreServices/KeyboardSetupAssistant.app

I'm not sure what governs its running. I can run it manually on one Mac with Mojave, but not another on Big Sur [It looks like it's going to launch, but doesn't].

3
  • Very nice find. Something else is going on, I’m still not sure if this checks a key value store in a keychain (or elsewhere)
    – bmike
    Commented Mar 7, 2022 at 14:48
  • 3
    On Monterey, you cannot run the app. When clicking, nothing happens.
    – coner
    Commented Aug 25, 2022 at 20:10
  • 1
    On Monterey I had to delete keyboardtype.plist in /Library/Preferences/, after reboot the assitant showed up
    – JoachimR
    Commented Sep 28, 2022 at 11:39
2

JoachimR's suggestion above was what fixed it for me, on Sonoma.

That is:

  1. Delete the following file /Library/Preferences/keyboardtype.plist
  2. Reboot.

Keyboard assistant will start after reboot.

0

I'm probably missing something, but try to go into System Preferences, Keyboard and then choose the Input Sources tab. Check the Show Input menu in menu bar (so you can choose your keyboard easily later) and -if needed- add any keyboard layout you may be missing from there. Btw, the only keyboards I could find with double quotes under the ESC key are Croation, Serbian and Slovenian... Is it one of these you mean with EU ?

1
  • It's not that a layout is missing, but it is not being recognized correctly. Every layout has 3 slightly different forms, to fit 3 different hardware keyboard "types:" ANSI, ISO, and JIS. Read the comments. Commented Aug 26, 2022 at 21:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .