0

My MacBook Pro came with a 500 GB hard disk, and I used about 250 GB. I was trying to get a new logic partition using the OSX disk utility, and then my Mac Book Pro froze and I had to quit the Disk Utility.

Then the available space just disappeared.

  • Disk Utility shows that the logic partition has a total capacity of 498.88 GB, available 10.48 GB, used 243.75 GB, which does not add up.
  • Disk Utility shows that the hard drive has a total capacity of 499.25 GB, available 19 MB, used 499.23 GB.
  • running df -h shows

    Filesystem     Size   Used  Avail Capacity  iused   ifree %iused  Mounted on 
    /dev/disk1     237Gi  227Gi  9.8Gi    96%   59509256      2559899 96%   /
    

Things I have tried:

  • all check and repair functions in Disk Utility
  • fsck -f
  • reboot and cmd+R and open the command line tool, but I cannot mount /dev/disk0 with -t hfs. It tells me resource busy
  • 1
    Please add the output of sudo gpt -r show /dev/disk0, diskutil list and diskutil cs list to your question. – klanomath Apr 13 '15 at 6:13
1

You probably tried to manipulate a CoreStorage volume with Disk Utility. Core Storage volumes are built after enabling File Vault 2, creating a Fusion Drive or often after updating to Yosemite.

If you don't have a second internal hard disk attached, disk0 is usually mounted to /. In your case disk1 is mounted to / which is a typical hint for Core Storage Volume Group - in case of an internal Fusion Drive disk2 is mounted to / and disk0 and disk1 usually don't appear entering df -h.

Open Terminal and enter diskutil cs list to get all CoreStorage objects in a tree-like view.

Use this comprehensive list of documented and undocumented commands to manipulate your CoreStorage Volume Group.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .