Somehow I have changed this, and I want to change it back. In Finder, on command-F "Find", I default to my home folder, not the current folder. (The "This Mac" choice is also there.) I don't remember how I did this, but I want it back to the default behavior. Other users on this machine do have the default behavior. I tried trashing ~/Library/Preferences/com.apple.spotlight.plist (or whatever it is called).
[MacOS 10.6.8]

1 Answer 1


Open Finder's Preference panel (Cmd-,). There, under the extended settings, you'll find a dropdown list that allows you to choose between "This Mac", the current folder or the last search range.

(Note: I checked this for a German Snow Leopard installation, so perhaps my re-translations may be a bit off -- sorry for that!)

  • I tried that before, it didn't work. But it suggested the problem is in Finder not Spotlight. So I trashed the Finder prefs. FIXED! Of course now I have to re-do the prefs that I want.
    – GEdgar
    Commented Jul 21, 2011 at 17:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .