3

Somehow the text field in System Information appears truncated: screenshot

If I reduce the overall size, the content of the bottom pane disappears, kind of goes below the left-hand pane:

enter image description here

It kind of seems like there is a missing horizontal scrollbar below the bottom pane, but I am not sure if there should be one there.

This doesn't affect only Audio, but many other ones fields.

I removed the font caches (although it is unlikely that it is caused by font issues); fixed the permissions (nothing that seemed related), but no go...

This is on a Retina Macbook Pro 13" (mid 2014) running OS X Yosemite 10.10.3, and the issue was also present on 10.10.2.

Any idea what is going on?

  • It looks like it's simply squished. Can you try collapsing/re-expanding the bottom detail section? Maybe resizing the window? Or defaults delete com.apple.systemprofiler? – jtbandes Apr 12 '15 at 7:39
  • do you have some 3d party audio stuff ? – Ruskes Apr 12 '15 at 7:48
  • @jtbandes: this is the maximum width, if I reduce the overal width past certain size, the content of the bottom pane disappears (kind of goes behind the left-hand pane), I added a screenshot – lupincho Apr 12 '15 at 7:51
  • @Buscar웃: no third party audio software or hardware; the issue affects many other fields, I added that to the question – lupincho Apr 12 '15 at 7:55
  • @jtbandes: As for the defaults command, initially after running the command running it doesn't fix now something happened and it shows Domain (com.apple.systemprofiler) not found. Defaults have not been changed. – lupincho Apr 12 '15 at 7:58
7

As determined in comments above, it seems as though your scrollbar settings were the problem :) I guess System Information is doing something unconventional with its window size due to the space taken up by the scrollbar when it's set to show Always...

3

When the scroll bars are shown, System Information seems to set its margins based on the window size when it's opened. So what happens is you widen the window to show more info, then quit, then reopen it, and then find you have to widen the window more to get the margins wide enough. This cycle repeats until you can't make the window any bigger and are stuck with too-narrow margins.

So, here's a workaround I found (other than hiding the scroll bars): open System Information, narrow the window as far as it'll go, then quit, reopen, narrow again. Repeat until the margins are somewhere near the actual window size.

Annoyingly, to maintain this you have to widen the window every time you open System Info (to get the window wide enough to display things), then narrow it before quitting so it won't be screwed up next time.

Update: this appears to be fixed in El Capitain (OS X 10.11). Also, I found another workaround for Yosemite: set the scroll bar mode for just System Information:

defaults write com.apple.SystemProfiler AppleShowScrollBars WhenScrolling
  • 1
    What's stupid is that if you disable/enable the scroll bars "always show" while System Info is open, it won't be affected. – cde Dec 27 '15 at 9:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .