0

In iPhoto, I put a shared iPhoto library on a network external hard drive accessed by multiple computers in the family. Even though two computer cannot access the library at the same time, the whole family can add to and edit the same (huge) library.

In Photos, I can't seem to select the "Photo Library.photoslibrary" from a second computer (via network shared drive).

If it's no longer possible to share a library from multiple computers, that would be a huge functionality loss for us - to not be able to keep one library for the whole family.

Our library is too large/expensive for iCloud Photo Library, which also would require all computers to sign in with the same iCloud account (no good for everything else).

UPDATE: since my shared Photo Library resides on an external hard drive, I tried attaching it directly to the second computer and then was allowed to select it (Option-launch Photos App) as well as setting it as the system library.

So it appears that the difference with iPhoto is that I can no longer share the library via network File Sharing (tried both smb and afp with no luck).

I really hope Apple allows this again as it's a hassle to detach/attach hard drives when we have high speed home network.

UPDATE 2: following Kevin's suggestion below, I tried creating a new Photos Library with only one photo added, and was able to access this library from another computer via network share. When trying to open the much larger library (converted from iPhoto library) from network share, Photos app showed a spinning wheel for a while and then returned an error message saying it could not open the library. The spinning wheel can persist for a long time, so I suspected it might be the sheer size of the library choking up the app. Indeed when I brought the computer into the same room as the wireless router, it did successfully open the library.

So bottomline is it still "works" provided the network speed is able to handle the size of the library.

1

Hold the alt (option) key while starting Photos App. You will be prompted to choose a Library.

  • Indeed I use that to choose different Photo Library, but the shared Photo Library - unless its containing disk is directly attached to the computer, not via File Sharing - can no longer be selected. – Kevin S. Apr 12 '15 at 13:37
  • It's probably not converted yet. Create a new Library on the NAS (you should be able to do that when you start with option-key) and go to File -> Import and select the library on the NAS – Kevin Grabher Apr 12 '15 at 13:40
  • Interesting suggestion - however, once attached directly, both the old iPhoto library (I didn't delete it yet) and the new Photos Library show up when option-launching the app. For the hell of it, I tried creating a new Library with only one photo added, I was indeed able to access it no problem, but still can not open the much larger shared one. I'm not sure if it's because of the size or if something more subtle with not "fully" converted. How do you make sure it's "fully" converted if that makes sense? – Kevin S. Apr 12 '15 at 13:54
  • Looks like a network issue - see above. Thanks for suggesting trying with a new library (I would upvote you except a newbie can't). – Kevin S. Apr 12 '15 at 14:22
  • Well, after the import I suppose the only indication that it has been fully imported is if the new Library is the same size as the old one. You could try to drag and drop all your pictures into Photos instead of migrating, If you can still open your library after that you'll see if it's a network or migration issue – Kevin Grabher Apr 12 '15 at 14:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .