8

Yesterday I updated iTunes in my iMac running OS X 10.10.3. According to the information in App Store, the new iTunes version is 12.1.2.

Since then iTunes won't start up. If I click on it, there is no response.

I figured that there is probably a known problem with the upgrade, and that this would be fixed in due course. However, I've been monitoring discussions, and there does not seem to be anything else who is having this problem.

Some research I did on how to solve this problem was to trash the iTunes preferences, and to download and re-install iTunes: I did both, but it still won't start up.

Nothing is logged on any error logs as far as I can see. I did a "tail -f /var/log/system.log" in Terminal App and then attempted to start iTunes, no messages were displayed.

When I try and open iTunes from terminal ("open -a iTunes"), I get a message: "LSOpenURLsWithRole() failed for the application /Applications/iTunes.app with error -10699."

Open With Role sounds as if there might be a permissions problem, I've repaired permissions with Disk Utility, and I've also tried starting iTunes from the command line using sudo, but no luck.

At this stage I've run out of ideas. Anybody else have an idea what I could try?

  • did you restart ? – Ruskes Apr 11 '15 at 23:24
  • Just installed the iTunes 12.1.2.27 update on my MBA 10.9.5 and it starts without problems. – Ruskes Apr 11 '15 at 23:33
  • Opening from Terminal "open -a iTunes" also works without problem. – Ruskes Apr 11 '15 at 23:40
  • @Buscar웃: I restarted multiple times. Thanks for the feedback that it works fine on your iMac. I had hoped that it other people with iMacs had the same issue (just to be sure: the upgrade worked fine on my Macbook, I encounter the problem on my iMac) but the problem seems to be specific to my machine. Ah well... – Jakkals Apr 12 '15 at 0:02
  • I tried to edit my comment above but I only had 5 minutes, Grrrr.. I wanted to say that the upgrade actually worked fine on my MBP as well. I was wondering whether the upgrade worked on other iMacs. – Jakkals Apr 12 '15 at 0:10
7

I had the same problem and was able to solve it by deleting iTunes and reinstalling.

The Finder tries quite hard to stop you from deleting iTunes; instead you can open Terminal.app and 'sudo rm -rf /Applications/iTunes.app'. You can download the replacement copy of iTunes from https://www.apple.com/itunes/download/

  • Have you encountered any side-effects from this? – alampros Apr 15 '15 at 12:43
  • I've changed this to be the correct answer. The solution proposed by @uasi was temporary, as he (she?) himself admitted. Following the instructions in this answer resulted in my problem being solved. – Jakkals Apr 16 '15 at 2:33
  • This worked for me too! It seems that the key is to to remove iTunes.app at first. Without removing it reinstallation resulted in nothing. – uasi Apr 17 '15 at 6:18
  • Didn't work for me. Loads for about 10 seconds and then crashes. – Joshua Pinter Jun 7 '15 at 16:08
  • Wait, I launched it again and it appears to be stable.... (So, I uninstalled it, reinstalled it, ran it once (crashes), and then ran it a second time (stable). – Joshua Pinter Jun 7 '15 at 16:10
2

As a temporary solution, you can execute iTunes binary directly by doing /Applications/iTunes.app/Contents/MacOS/iTunes in the terminal.

Code -10699 returned by open -a iTunes indicates some error in Launch Services (similar error codes are documented but the very thing is not). Executing binary in this way somehow sidesteps the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .