1

Trying to copy a 37GB Quicktime .mov from an external disk using the Finder.

The copy should take a few minutes, and show a progress window. But the copy seems to be done immediately (no progress window and no error message), and the resulting file is 0 bytes.

The problem is only with the Finder. Copying the file in Terminal, or another file manager like muCommander works.

I'm using Mac OS x 10.8.5.

The source is a normal external Mac disk (HFS+), and the file doesn't have any attributes as shown by ls -l@ or xattr -l. File mode is 0600, and owner is me:staff.

The destination is irrelevant. Even trying to "Duplicate" the file using the Finder's right-click menu gives the same result: a zero byte duplicate.

I tried restarting, verifying the disk in Disk Utility, etc. The problem remains with this particular file, even though there doesn't seem to be anything special about it.

Update:

A copy of the file (using Treminal) to the same folder can be be copied without trouble. (The original and the copy are really identical, according to md5)

Renaming the file in Finder doesn't help.

Deleting the .DS_Store file in the folder and remounting the drive doesn't help.

Really weird...

  • All other files on this external disk copy OK? Have you tried a right-click > Copy [filename], then focus on a target location on another disk and right-click > Paste Item? How about a right-click > Duplicate onto the same volume (assuming there's enough free space?) Lastly, what OS X version and how much free space on the source external drive? – IconDaemon Apr 11 '15 at 14:36
  • @IconDaemon: Yes, other files copy fine (including big files); Yes, space is fine; No, other ways to copy or duplicate in Finder don't work, whether to the same or to another disk. – mivk Apr 11 '15 at 14:44
  • 1
    I suggest then than you copy the .mov using Terminal to another volume, make sure that the copied .mov file plays from beginning to end, (no corruption,) then delete the 'bad' copy on the external disk. To be even more cautious, I'd backup all the data on the external drive and reformat it. Lastly, to be really obsessive-compulsive about it, I'd format and write with one or more passes of zeroes to give the drive a good physical workout. I've had two USB external 2.5" and one Firewire 3.5" drives demonstrate their unworthiness over the years by failing a pass or two of zeros. – IconDaemon Apr 11 '15 at 14:50
  • Wow, this is an interesting issue and I wish I had a definitive answer unfortunately I do not. If you have enough free space on the external drive, if you copy the file using Terminal or muCommander to the same external drive to a different name or location on that drive... then can that copy be copied with Finder successfully to the internal drive? – user3439894 Apr 11 '15 at 14:59
  • In your "Update:" when you say "A copy of the file (using Treminal) to the same folder can be be copied without trouble." are you saying you copied the original file on the external drive to the external drive and then copied the copy via Finder to the internal drive successfully? Because as worded it it not explicitly clear that's the case although I assume yes since you posted the update after my first comment. – user3439894 Apr 11 '15 at 16:01

You must log in to answer this question.

Browse other questions tagged .