1

Suddenly, the option to open in Safari is missing from my share menu. It's not even listed in the "More" options menu. The only unusual thing I've done recently is to install iCloud for Windows on my laptop at work. It never did fully install, however, so I'm not sure how that could affect anything as I sync to iTunes on a MacBook Air.

This is apparent in apps that use the horizontal icon-based share menu—e.g. Tweetbot or ABC News—the Safari option is gone. The share menu is different in other apps like Twitter or Facebook (where it's a vertical text list) and "open in Safari" is still an option in those.

Is anyone else having this problem? I've tried Googling this with no success. I've also cleared all Safari data and tried a reset with no luck.

What am I missing? I'm on an iPhone 6 running the latest iOS 8.3. 😕

  • 1
    Missing from the share menu in what app? – grg Apr 11 '15 at 13:15
  • 1
    Tweetbot! I use it so often, it didn't even occur to me that it was app related. The menu is different in other apps like Twitter, Facebook (vertical list) and "open in Safari" is in those. But in apps that use the horizontal icon-based share menu —another example is ABC News app— the Safari option is gone. – Chiquitanita Apr 11 '15 at 14:00
  • Could you add this detail to your question? – grg Apr 11 '15 at 14:02
  • I'm still confused. The sideways icon share menu is present in many places, for example Photos, but you can't share a photo to Safari, now or ever? Open in Safari depends entirely on the app developer's support to add the share extension? – grg Apr 11 '15 at 14:21
  • It's always been in the Tweetbot app, which I use a lot, but admit I'm not sure if it was in the other apps... Still, it just disappeared from Tweetbot. I don't think it happened when I updated to 8.3 as I didn't notice it until yesterday (not only do I use Tweetbot many many times/day, I frequent click through to read stories and often used the share sheer to open in Safari). Maybe Tweetbot removed it, then. I'll reach out to them and ask. – Chiquitanita Apr 11 '15 at 14:27
1

One of the recent version update changelogs for Tweetbot states they made a change to the share sheet, which may in turn have caused a bug that is preventing Safari from showing up. This would best be reported to the developer of the app.

In iOS 8.x, a developer basically advertises "I have this type of data to be shared, what apps can share it?" The system responds with a list of apps that are capable of receiving that type of data. (Types can include text, a web URL, images, and so forth.) Depending on what type of data Tweetbot is advertising, it may not be compatible with what Safari says it can receive - Tweetbot might be advertising the URL in plain text format, whereas Safari might only be able to receive the URL specifically formatted as a URL.

1

On iOS 9, it looks like Apple has intentionally removed the "Open In..." option on certain file extensions like PPT and XLS.

It has already been reported here: Cannot Save Documents in Safari?

I have spoken to Apple Customer Support and they recommended to me several workarounds, which include:

  • Converting the file into a PDF and reading it;
  • Using a third-party browser like Chrome, which brings back the "Open In" option.

Second option worked best for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .