1

After installing the most recent security and Safari updates (7.1.5) on Mavericks, Safari and other applications (those using NSURLConnection/CFURLConnection) no longer recognize any root certificates as valid. The root certificates in the System Roots keychain seem to be fine, as far as Keychain Access is concerned. However, Safari, iTunes, Chrome, etc. fail to validate all root certificates ("This certificate was signed by an unknown authority"). Already tried deleting the /var/db/crls/crlcache.db and /var/db/crls/ocspcache.db to no effect. System time is correct. Any ideas?

2

Were able to solve the issue myself. For some reason, there were a few root certificates in my login Keychain, which have been revoked and replaced with newer certs in the System Roots keychain. Deleted those certs from my login keychain and everything works fine again.

  • I had the same problem and this solved it. Thank you! I wonder how that happened in the first place. – alcarv Apr 12 '15 at 21:41
  • You've probably installed a root certificate manually and it ended up in your login toolchain. That's what likely happened in my case. – Günter Obiltschnig Apr 13 '15 at 21:06
  • How do I do that? Can someone please walk me through the steps? How do you find and recognize them? I have this problem and I think this would fix it. Thank you. – user148773 Sep 27 '15 at 1:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .