116

⌃ Control+ and ⌃ Control+ switches desktops.

I actually had this enabled in Spaces on Snow Leopard, but I'd like to turn this off because I use those key combinations when editing in Eclipse. How do I turn this off?

2 Answers 2

150

Go to System Preferences > Keyboard > Shortcuts > Mission Control and change the settings for "Move left a space" and "Move right a space" or disable them completely.

4
  • 16
    It's easy to mix up and go to "System Preferences > Mission Control > Shortcuts" instead, where you will only see options for the Ctrl + Up/Down shortcuts, but not the Ctrl + Left/Right ones!
    – rleelr
    Dec 20, 2017 at 22:48
  • In OS X Catalina these options are in the "System Preferences > Keyboard > Shortcuts > Mission Control"
    – akronymn
    Dec 23, 2020 at 14:36
  • @rleelr : Your comment saved me. Thanks :) Aug 12, 2021 at 11:22
  • Interestingly, after doing this, CTRL-LEFT ARROW works but RIGHT doesn't...?
    – Krumelur
    Jan 17 at 11:40
6

I updated an app called Karabiner and it turned some Mission Control shortcuts off. I like moving desktops. Here's how you turn them back on:

https://i.imgur.com/W6bd9z8.png

2
  • 1
    Is there a way to get karabiner to send "move left a space" and "move right a space" commands. I would like to continue to have control left/right to execute those commands, but I would also like to have a one handed option (eg right command comma and right command period)
    – ORcoder
    Nov 21, 2019 at 21:51
  • @ORcoder, yes, Karabiner is quite configurable. You may need to add a rule to ~/.config/karabiner/karabiner.json configuration file but it's pretty easy to do, just look at the rest of the file for examples.
    – user118967
    May 5, 2021 at 5:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .