10

I continue to get this error each time I try to install xcode: "Xcode failed to download, use the purchases page to try again"

This is with the newest OSX 10.10.3.

I found this thread: Xcode failed to download. Use the Purchases page to try again

I tried the two possible solutions: 1) Resetting the App Store app via "Debug --> Reset Application" does nothing as far as I can tell (there's no visual feedback that selecting that option does anything). 2) I tried to find the plist file in /private/var/folders/, but the directory there is empty.

I've tried deleting xcode, reinstalling, etc, etc. I found this crash report via system log which...seems bad...seg fault?:

Process:               softwareupdated [711]
Path:                  /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated
Identifier:            softwareupdated
Version:               744.10
Code Type:             X86-64 (Native)
Parent Process:        launchd [1]
Responsible:           softwareupdated [711]
User ID:               200

Date/Time:             2015-04-10 10:00:00.603 -0700
OS Version:            Mac OS X 10.10.3 (14D131)
Report Version:        11
Anonymous UUID:        <redacted>

Sleep/Wake UUID:       <redacted>

Time Awake Since Boot: 7300 seconds
Time Since Wake:       980 seconds

Crashed Thread:        11  Dispatch queue: com.apple.SoftwareUpdate.SUCatalogDataManager.Handler

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x000000012f939380

VM Regions Near 0x12f939380:
    MALLOC_LARGE           000000010c43f000-000000010d293000 [ 14.3M] rw-/rwx SM=PRV  
--> 
    JS JIT generated code  00003bb82f600000-00003bb82f601000 [    4K] ---/rwx SM=NUL  
  • Could you please add the complete crash log? Use someone like PasteBin or GhostBin if the log is too long to paste here. – Spotlight Apr 10 '15 at 17:17
  • It turned out that my hard drive was faulty. So if you're getting these types of problems on and off yours could be too. – Eric Conner Nov 8 '15 at 18:07
13

I encountered this problem many times, and I found today that it's caused by lack of disk space.

In my machine there is more than 7GB spare space, and after downloading the files, it reported this error.

Today I find the real problem from /private/var/log/install.log, it is caused by low disk space, so I made more space, and the update succeeded.

Since the download is 6 GB you'll want to delete old versions and have at least 15 GB free space before trying again to download. Look in /var/folders for paused / stuck downloads as well as perhaps cleaning any local time machine snapshots once you delete a large app like Xcode. Even after emptying trash, it will consume space for a few days or longer if you don't regularly have a Time Machine volume attached to let the snapshots age out.

  • 1
    That was my problem as well even though there was ~14 GB available. The solution was to delete the previous Xcode version which was coming from developer.apple.com and then free space reached ~20 GB. – Pol Oct 25 '15 at 20:25
1

So I eventually succeeded in installing Xcode. Here's what I ended up doing:

  1. I signed out of the App Store using Store --> Sign Out.
  2. I reboot the machine and held Command + R to enter the disk utility.
  3. I ran the disk verification utilities and made sure everything came out ok.
  4. After restarting the machine again I was able to install xcode.

No idea if all or any of those steps were required, but eventually I was able to get it to install.

  • Not useful. Now my Mac thinks it installed the XCode update and it hasn't installed it. It's stuck in "waiting" forever. – 2rs2ts Oct 6 '15 at 19:58
1

I had this exact problem, and none of the above helped at all. Eventually, I logged out of the App Store, and went to the Applications folder where I deleted Xcode.app. I then emptied the trash. Then restarted my computer and logged back in to the App Store. DON'T try to reload from the Purchases page - go to Featured page, search for Xcode and load again, fresh. Bingo! It finally got past the roadblock and installed. Hope this helps.

1

I had the same problem. I did a spotlight search for "Xcode" to find the previous version, and the user license agreement popped up. Once I agreed, the installation finished.

0

I encountered this exact problem myself and the only advice I can give you is to:

  1. Log out of App Store. Store > Sign out.

  2. Restart your computer, hold down Command R and wait till disk utility appears. Then close the window, select your disk and finish the restart.

  3. Relaunch appstore, log in, and restart again, no disk utility this time.

  4. Then start Update/Download, make sure to monitor your computer and do NOT let it fall asleep. All done.

Hope this helps. This worked for me.

0

I reviewed /private/var/log/install.log to find the error and couldn't find one, so I removed it, and reran the install from the app store panel and it worked.

Dunno what and if something else had changed.

  • In your answer, did you remove the program or the log file? It's not clear what you are referring to. – Allan Apr 27 '16 at 11:13
0

None of the above worked for me. I tried all of it (Shut off all anti-virus apps; deleted old downloads, rebooted; turned on App Store Debug; debugged to the lowest level; restarted the App Store; cleared cookies; sacrificed a chicken to the Xcode gods) but no joy.

I did find this following line in my /var/log/commerce.log at the time the install failed:

blah blah:SoftwareMap: No app was found with bundle ID com.apple.dt.Xcode to upgrade to 7.3.1

Now I have never had Xcode on my machine before, and that line suggests that the download (and install) failed because it was an UPGRADE and I did not have the previous version.

Thoughts PLEASE???

0

Sometimes XCode updates depend on an OS "Tools" Update. If a separate OS update is available, install that update first before attempting to update XCode.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .