9

I am having problems installing the old version of grails on my mac, with homebrew.

The spot where I get stuck is at the brew versions grails as it will say that versions is no longer used. I have executed brew tap homebrew/versions but the versions command do still not work. How in the newest version of brew can I install Grails 2.3.5?

Error: The `versions` command is no longer supported.
You can use the homebrew-versions tap instead:
  https://github.com/Homebrew/homebrew-versions
Or use `brew log` to browse the git history.
4
brew tap homebrew/versions

then:

brew install homebrew/versions/grails23

brew search grails will show you all the available ones to install.

  • 1
    grails23 is not 2.3.5 – Androme Apr 12 '15 at 20:36
  • 1
    I brew search python but don't get minor versions of Python. I'm trying to get 2.7.9 or later! – Rikki Oct 31 '16 at 12:51
  • brew search grails returns only 2 entries for me: grails homebrew/versions/grails25 – Alex Mar 6 '17 at 15:25
0

It seems to be very easy as of right now:

user@MacBook-Pro:~/% brew search grails        
grails ✔                                                                                                         grails@2.5
user@MacBook-Pro:~/% brew install grails@2.5
  • This unfortunately does not work for uncrustify. It does not find old formulas. – Fawkes Jun 14 '17 at 11:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .