3

I can't seem to find a definitive answer anywhere, but are Mac OS X Security Updates cumulative?

The update in question is 2015-004. I've checked https://support.apple.com/en-us/HT204659 but it doesn't list any requirements.

Background: I've just finished deploying 2015-002 to some of our iMacs (running Mavericks 10.9.5), but now I see that 2015-004 is out. I was wondering if there was any point in continuing rolling out 2015-002, or should I just deploy 2015-004?

1

I would assume not cumulative, based on 15 years on Mac, and continue with -002.

Absolutely there's a point, one never knows what little fixes are included in each Security Update, nor what might be dependent on previous updates.

Bite the bullet and play by the Apple book.

  • Thank you. I've decided to update to 002 first to be on the safe side. The funny thing is, on one of the computers, 002 was never installed but the App Store was showing only 004 as the available update. I had to search the web and find the URL for the 002 pkg and manually download it. I wish there was a better way to find out the direct links to the updates. – d3Xt3r Apr 12 '15 at 21:01
  • I downvoted this. OP's question "Are security updates cumulative [since the last point release]?" should have a simple yes or no answer, which does not change between releases (unless Apple is very incompetent, which I doubt). Unless I'm misreading, this answer is basically responding "I don't know", which, well, isn't particularly helpful information. :) – Wowfunhappy Aug 6 at 17:26
0

I agree with Zo219 and wanted to add some other thoughts.

Reading the article - the security fixes are present in both 10.10.3 and update 2005-004. Those fixes are clearly not in 2015-002 so you'll want to finish 002 and then evaluate if you're jumping to 10.10.3 or will need to apply 2015-004 as a stopgap before .3 can be rolled out.

Based on how fast you could package, test and deploy 004 that would guide me in stopping work on 002. I'd only stop 002 if I knew I could deploy 10.10.3 and finish as soon as 002 would be done.


As a general rule, point updates almost universally roll in all intermediate security updates. So, 10.10.3 will have all the security updates post 10.10.2 - but if there are three hypothetical updates between 10.10.3 and 10.10.4, you'll need all three updates to be patched to be secure since they do not historically roll up.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .